]> code.ossystems Code Review - openembedded-core.git/commitdiff
eglibc: Fix build for e500 cores
authorKhem Raj <raj.khem@gmail.com>
Wed, 18 Jul 2012 06:39:40 +0000 (23:39 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 18 Jul 2012 13:28:44 +0000 (14:28 +0100)
e500 support needed to be updared to match eglibc 2.16

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/eglibc/eglibc-2.16/e500-math_private.patch [new file with mode: 0644]
meta/recipes-core/eglibc/eglibc_2.16.bb

diff --git a/meta/recipes-core/eglibc/eglibc-2.16/e500-math_private.patch b/meta/recipes-core/eglibc/eglibc-2.16/e500-math_private.patch
new file mode 100644 (file)
index 0000000..9dbb26e
--- /dev/null
@@ -0,0 +1,31 @@
+Match with the latest math_private restructuring in glibc
+
+as done here
+
+http://sourceware.org/ml/libc-alpha/2012-03/msg00302.html
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+
+Index: libc/ports/sysdeps/powerpc/powerpc32/e500/fpu/math_private.h
+===================================================================
+--- libc.orig/ports/sysdeps/powerpc/powerpc32/e500/fpu/math_private.h  2012-07-17 22:58:20.340405923 -0700
++++ libc/ports/sysdeps/powerpc/powerpc32/e500/fpu/math_private.h       2012-07-17 22:58:21.120405923 -0700
+@@ -1 +1 @@
+-#include <math/math_private.h>
++#include_next <sysdeps/generic/math_private.h>
+Index: libc/ports/sysdeps/powerpc/powerpc32/e500/fpu/fraiseexcpt.c
+===================================================================
+--- libc.orig/ports/sysdeps/powerpc/powerpc32/e500/fpu/fraiseexcpt.c   2012-07-17 23:15:15.872405939 -0700
++++ libc/ports/sysdeps/powerpc/powerpc32/e500/fpu/fraiseexcpt.c        2012-07-17 23:18:42.760405602 -0700
+@@ -23,7 +23,7 @@
+ #undef feraiseexcept
+-#define __FERAISEEXCEPT_INTERNAL feraiseexcept
++#define __FERAISEEXCEPT_INTERNAL __feraiseexcept
+ #include "../spe-raise.c"
+-libm_hidden_def (feraiseexcept)
++libm_hidden_ver (__feraiseexcept, feraiseexcept)
index 09f5dbbe059d41976c13796dbe17cd5cf0a8ebbe..23a41301855624279938c469392db9fa70ed2f6c 100644 (file)
@@ -3,7 +3,7 @@ require eglibc.inc
 SRCREV = "19383"
 
 DEPENDS += "gperf-native"
-PR = "r0"
+PR = "r1"
 PR_append = "+svnr${SRCPV}"
 
 EGLIBC_BRANCH="eglibc-2_16"
@@ -22,6 +22,7 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=h
            file://eglibc_fix_findidx_parameters.patch \
            file://ppc_slow_ieee754_sqrt.patch \
            file://rpc-bootstrap.patch \
+           file://e500-math_private.patch \
           "
 LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
       file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \