]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: fix B != S
authorRobert Yang <liezhi.yang@windriver.com>
Tue, 13 Jan 2015 02:55:19 +0000 (18:55 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 16 Jan 2015 23:06:46 +0000 (23:06 +0000)
And bump PR to avoid:
gcc: error: Parser/tokenizer_pgen.o: No such file or directory
gcc: error: Parser/printgrammar.o: No such file or directory
gcc: error: Parser/pgenmain.o: No such file or directory

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-devtools/python/python.inc
meta/recipes-devtools/python/python3_3.3.3.bb
meta/recipes-devtools/python/python_2.7.3.bb

index 19942baeb0fd13fd397d995a0b07bcec1f56f053..bc5e5b91f70cddc5a7b4f7a9ba5347b27e5bd94b 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.python.org"
 LICENSE = "PSFv2"
 SECTION = "devel/python"
 # bump this on every change in contrib/python/generate-manifest-2.7.py
-INC_PR = "r0"
+INC_PR = "r1"
 
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ed3abfd1059e2d3a36a8cff3986f9bb6"
 
@@ -14,7 +14,7 @@ SRC_URI[sha256sum] = "726457e11cb153adc3f428aaf1901fc561a374c30e5e7da6742c0742a3
 
 PYTHON_MAJMIN = "2.7"
 
-inherit autotools-brokensep
+inherit autotools
 
 PYTHONLSBOPTS = "--with-wctype-functions"
 PYTHONLSBOPTS_linuxstdbase = "ac_cv_sizeof_off_t=8"
index 2c1f63f5b881d013e48a538a3e17c7f647df1b90..efa98c09fa996fcfd149519d240b991435aad3e8 100644 (file)
@@ -76,7 +76,7 @@ do_configure_prepend() {
 
 do_compile() {
         # regenerate platform specific files, because they depend on system headers
-        cd Lib/plat-linux*
+        cd ${S}/Lib/plat-linux*
         include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
                 ${S}/Tools/scripts/h2py.py -i '(u_long)' \
                 ${STAGING_INCDIR}/dlfcn.h \
@@ -108,7 +108,7 @@ do_compile() {
        install -m 0644 Makefile Makefile.sysroot
 
        export CROSS_COMPILE="${TARGET_PREFIX}"
-       export PYTHONBUILDDIR="${S}"
+       export PYTHONBUILDDIR="${B}"
        oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python3-native/pgen \
                HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python3-native/python3 \
                STAGING_LIBDIR=${STAGING_LIBDIR} \
@@ -136,7 +136,7 @@ do_install() {
        install -m 0644 Makefile.orig Makefile
 
        export CROSS_COMPILE="${TARGET_PREFIX}"
-       export PYTHONBUILDDIR="${S}"
+       export PYTHONBUILDDIR="${B}"
        install -d ${D}${libdir}/pkgconfig
        install -d ${D}${libdir}/python${PYTHON_MAJMIN}/config
 
index 9ded75b3734e826f54e9623b7c967e5529d22530..90b397f3ce72fa65c41d682747aa265d1b3ba551 100644 (file)
@@ -61,7 +61,7 @@ do_configure_prepend() {
 
 do_compile() {
         # regenerate platform specific files, because they depend on system headers
-        cd Lib/plat-linux2
+        cd ${S}/Lib/plat-linux2
         include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python-native/python \
                 ${S}/Tools/scripts/h2py.py -i '(u_long)' \
                 ${STAGING_INCDIR}/dlfcn.h \
@@ -93,7 +93,7 @@ do_compile() {
        install -m 0644 Makefile Makefile.sysroot
 
        export CROSS_COMPILE="${TARGET_PREFIX}"
-       export PYTHONBUILDDIR="${S}"
+       export PYTHONBUILDDIR="${B}"
 
        oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python-native/pgen \
                HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \
@@ -110,7 +110,7 @@ do_install() {
        install -m 0644 Makefile.orig Makefile
 
        export CROSS_COMPILE="${TARGET_PREFIX}"
-       export PYTHONBUILDDIR="${S}"
+       export PYTHONBUILDDIR="${B}"
 
        # After swizzling the makefile, we need to run the build again.
        # install can race with the build so we have to run this first, then install