]> code.ossystems Code Review - openembedded-core.git/commitdiff
uclibc: fix compile error on i586
authorPhil Blundell <pb@pbcl.net>
Fri, 10 Jun 2011 13:56:09 +0000 (14:56 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 14 Jun 2011 12:23:49 +0000 (13:23 +0100)
Without this you get:

| libc/sysdeps/linux/common/epoll.c: In function '__libc_epoll_pwait':
| libc/sysdeps/linux/common/epoll.c:71:80: error: memory input 7 is not directly addressable
| libc/sysdeps/linux/common/epoll.c:75:86: error: memory input 7 is not directly addressable
| make: *** [libc/sysdeps/linux/common/epoll.o] Error 1

Signed-off-by: Phil Blundell <philb@gnu.org>
meta/recipes-core/uclibc/uclibc-git/epoll-asm-fix.patch [new file with mode: 0644]
meta/recipes-core/uclibc/uclibc_git.bb

diff --git a/meta/recipes-core/uclibc/uclibc-git/epoll-asm-fix.patch b/meta/recipes-core/uclibc/uclibc-git/epoll-asm-fix.patch
new file mode 100644 (file)
index 0000000..bcd834d
--- /dev/null
@@ -0,0 +1,25 @@
+Fix a compile error due to last argument to syscall() not being memory addressable.
+
+Upstream-Status: Pending
+Signed-off-by: Phil Blundell <philb@gnu.org>
+
+diff --git a/libc/sysdeps/linux/common/epoll.c b/libc/sysdeps/linux/common/epoll.c
+index 85b0cfd..c034b2c 100644
+--- a/libc/sysdeps/linux/common/epoll.c
++++ b/libc/sysdeps/linux/common/epoll.c
+@@ -67,12 +67,13 @@ extern __typeof(epoll_pwait) __libc_epoll_pwait;
+ int __libc_epoll_pwait(int epfd, struct epoll_event *events, int maxevents,
+                                               int timeout, const sigset_t *set)
+ {
++      int nsig = _NSIG / 8;
+       if (SINGLE_THREAD_P)
+-              return INLINE_SYSCALL(epoll_pwait, 6, epfd, events, maxevents, timeout, set, _NSIG / 8);
++              return INLINE_SYSCALL(epoll_pwait, 6, epfd, events, maxevents, timeout, set, nsig);
+ # ifdef __UCLIBC_HAS_THREADS_NATIVE__
+       else {
+               int oldtype = LIBC_CANCEL_ASYNC ();
+-              int result = INLINE_SYSCALL(epoll_pwait, 6, epfd, events, maxevents, timeout, set, _NSIG / 8);
++              int result = INLINE_SYSCALL(epoll_pwait, 6, epfd, events, maxevents, timeout, set, nsig);
+               LIBC_CANCEL_RESET (oldtype);
+               return result;
+       }
index 78ef4f28d90bef5a6b33d2a075b9b1cc73fec9e3..b8f58f00958199cdce1ebd1d425a7c4e2ceee6b7 100644 (file)
@@ -26,5 +26,6 @@ SRC_URI = "git://uclibc.org/uClibc.git;branch=master;protocol=git \
        file://remove_attribute_optimize_Os.patch \
        file://append_UCLIBC_EXTRA_CFLAGS.patch \
        file://compile-arm-fork-with-O2.patch \
+       file://epoll-asm-fix.patch \
        "
 S = "${WORKDIR}/git"