]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-rp-2.6.23+2.6.24: Add missing patches
authorRichard Purdie <richard@openedhand.com>
Fri, 19 Oct 2007 10:35:27 +0000 (10:35 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 19 Oct 2007 10:35:27 +0000 (10:35 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2912 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/linux/linux-rp-2.6.23+2.6.24-rc0+git/mmcsd_no_scr_check-r2.patch [new file with mode: 0644]
meta/packages/linux/linux-rp-2.6.23+2.6.24-rc0+git/w100fb-unused-var.patch [new file with mode: 0644]
meta/packages/linux/linux-rp_2.6.23+2.6.24-rc0+git.bb

diff --git a/meta/packages/linux/linux-rp-2.6.23+2.6.24-rc0+git/mmcsd_no_scr_check-r2.patch b/meta/packages/linux/linux-rp-2.6.23+2.6.24-rc0+git/mmcsd_no_scr_check-r2.patch
new file mode 100644 (file)
index 0000000..ac2245f
--- /dev/null
@@ -0,0 +1,29 @@
+---
+ drivers/mmc/core/sd.c |   11 ++++++-----
+ 1 file changed, 6 insertions(+), 5 deletions(-)
+
+Index: linux-2.6.23/drivers/mmc/core/sd.c
+===================================================================
+--- linux-2.6.23.orig/drivers/mmc/core/sd.c    2007-10-17 11:33:26.000000000 +0200
++++ linux-2.6.23/drivers/mmc/core/sd.c 2007-10-17 11:33:49.000000000 +0200
+@@ -173,14 +173,15 @@
+       scr_struct = UNSTUFF_BITS(resp, 60, 4);
+       if (scr_struct != 0) {
+-              printk(KERN_ERR "%s: unrecognised SCR structure version %d\n",
++              printk(KERN_WARNING "%s: unrecognised SCR structure version %d\n",
+                       mmc_hostname(card->host), scr_struct);
+-              return -EINVAL;
++              scr->sda_vsn = 0;
++              scr->bus_widths = 0;
++      } else {
++              scr->sda_vsn = UNSTUFF_BITS(resp, 56, 4);
++              scr->bus_widths = UNSTUFF_BITS(resp, 48, 4);
+       }
+-      scr->sda_vsn = UNSTUFF_BITS(resp, 56, 4);
+-      scr->bus_widths = UNSTUFF_BITS(resp, 48, 4);
+-
+       return 0;
+ }
diff --git a/meta/packages/linux/linux-rp-2.6.23+2.6.24-rc0+git/w100fb-unused-var.patch b/meta/packages/linux/linux-rp-2.6.23+2.6.24-rc0+git/w100fb-unused-var.patch
new file mode 100644 (file)
index 0000000..8cbbb6b
--- /dev/null
@@ -0,0 +1,17 @@
+From: Marcin Juszkiewicz <openembedded@haerwu.biz>
+
+drivers/video/w100fb.c: In function ‘w100fb_imageblit’:
+drivers/video/w100fb.c:507: warning: unused variable ‘par’
+
+Signed-off-by: Marcin Juszkiewicz <openembedded@haerwu.biz>
+
+--- linux-2.6.23/drivers/video/w100fb.c        2007-10-11 16:52:30.000000000 +0200
++++ linux-2.6.23/drivers/video/w100fb.c        2007-10-15 12:56:01.000000000 +0200
+@@ -504,7 +504,6 @@ static void w100_hostdata(u32 width, u32
+ static void w100fb_imageblit(struct fb_info *info,
+                              const struct fb_image *image)
+ {
+-      struct w100fb_par *par = info->par;
+       union dp_gui_master_cntl_u gmc;
+       u32 fgcolor, bgcolor;
index 8ed38f31c18e8d45b02359113bff906bb0982210..93ffe19b6e9cc7655f9c4c1f2298aa035848a1f8 100644 (file)
@@ -1,6 +1,6 @@
 require linux-rp.inc
 
-PR = "r0"
+PR = "r1"
 
 DEFAULT_PREFERENCE = "-1"
 
@@ -36,12 +36,14 @@ SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2 \
            ${RPSRC}/pxa27x_overlay-r7.patch;patch=1 \
            ${RPSRC}/w100_extaccel-r1.patch;patch=1 \
            ${RPSRC}/w100_extmem-r1.patch;patch=1 \
+           file://w100fb-unused-var.patch;patch=1 \
            file://hostap-monitor-mode.patch;patch=1 \
            file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1 \
            ${RPSRC}/logo_oh-r1.patch.bz2;patch=1;status=unmergable \
            ${RPSRC}/logo_oz-r2.patch.bz2;patch=1;status=unmergable \
            ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable \
            ${RPSRC}/mmcsd_large_cards-r1.patch;patch=1;status=hack \
+           file://mmcsd_no_scr_check-r2.patch;patch=1 \
            ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack \
            ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack \
            ${RPSRC}/corgi_rearrange_lcd-r0.patch;patch=1 \