]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/4.1: v4.1.24 and gcc6 powerpc fixes
authorBruce Ashfield <bruce.ashfield@windriver.com>
Tue, 24 May 2016 15:53:58 +0000 (11:53 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 25 May 2016 06:49:55 +0000 (07:49 +0100)
Bumping to the v4.1.24 -stable release, and backporting a ppc
gcc6 fix from the 4.4 kernel.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
meta/recipes-kernel/linux/linux-yocto_4.1.bb

index 090f8f3310b053465b9ca8e8b55465bccabddaee..51fa3adeb2097e1eb1e7d9334e347ec71225517c 100644 (file)
@@ -11,13 +11,13 @@ python () {
         raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
 }
 
-SRCREV_machine ?= "51cca91a1f74dab225598282019f0d694abdc4a0"
-SRCREV_meta ?= "2bdebd11f1a0bc00071ec1467289a7feb5418dde"
+SRCREV_machine ?= "320892013ad33ab41f530ad321939aec07d09d22"
+SRCREV_meta ?= "d6e1f4bfc254c677a8dfef92f0ad8c78bdeeea75"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.1;destsuffix=${KMETA}"
 
-LINUX_VERSION ?= "4.1.22"
+LINUX_VERSION ?= "4.1.24"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index 04853a9aa61b4e623a5f1e236c451fa3c1a1a529..35a76ef0cd07d5a5dc0a9bae2e9a815d491fa19b 100644 (file)
@@ -4,13 +4,13 @@ KCONFIG_MODE = "--allnoconfig"
 
 require recipes-kernel/linux/linux-yocto.inc
 
-LINUX_VERSION ?= "4.1.22"
+LINUX_VERSION ?= "4.1.24"
 
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine ?= "d03753ddb28a1141e550a67c99ac95789a424fc5"
-SRCREV_meta ?= "2bdebd11f1a0bc00071ec1467289a7feb5418dde"
+SRCREV_machine ?= "ecc983477682203619da0e456fa4a8689ac41097"
+SRCREV_meta ?= "d6e1f4bfc254c677a8dfef92f0ad8c78bdeeea75"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index 5d6bd3d31fa67d8cff3dc91870c269977143fd22..2332e11f42edf9bf684cf380d0daa39ea14ea40b 100644 (file)
@@ -11,20 +11,20 @@ KBRANCH_qemux86  ?= "standard/base"
 KBRANCH_qemux86-64 ?= "standard/base"
 KBRANCH_qemumips64 ?= "standard/mti-malta64"
 
-SRCREV_machine_qemuarm ?= "f781d64949f776cbfa5274a548becdcf6b596341"
-SRCREV_machine_qemuarm64 ?= "d03753ddb28a1141e550a67c99ac95789a424fc5"
-SRCREV_machine_qemumips ?= "192043960081896baaa24c2af702c7124bfe4286"
-SRCREV_machine_qemuppc ?= "d03753ddb28a1141e550a67c99ac95789a424fc5"
-SRCREV_machine_qemux86 ?= "d03753ddb28a1141e550a67c99ac95789a424fc5"
-SRCREV_machine_qemux86-64 ?= "d03753ddb28a1141e550a67c99ac95789a424fc5"
-SRCREV_machine_qemumips64 ?= "351bc6968f63ea6f27cbd7f1678ddc53a9168fd1"
-SRCREV_machine ?= "d03753ddb28a1141e550a67c99ac95789a424fc5"
-SRCREV_meta ?= "2bdebd11f1a0bc00071ec1467289a7feb5418dde"
+SRCREV_machine_qemuarm ?= "d11c336b38ab0d4e55eb683aca5ca9c6b6cd8b42"
+SRCREV_machine_qemuarm64 ?= "ecc983477682203619da0e456fa4a8689ac41097"
+SRCREV_machine_qemumips ?= "f8e363f638b283738369155b4a9990b5d0f902a7"
+SRCREV_machine_qemuppc ?= "ecc983477682203619da0e456fa4a8689ac41097"
+SRCREV_machine_qemux86 ?= "ecc983477682203619da0e456fa4a8689ac41097"
+SRCREV_machine_qemux86-64 ?= "ecc983477682203619da0e456fa4a8689ac41097"
+SRCREV_machine_qemumips64 ?= "1db47ec6c39071b29f82a040b9b9a81584f50461"
+SRCREV_machine ?= "ecc983477682203619da0e456fa4a8689ac41097"
+SRCREV_meta ?= "d6e1f4bfc254c677a8dfef92f0ad8c78bdeeea75"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.1;destsuffix=${KMETA}"
 
-LINUX_VERSION ?= "4.1.22"
+LINUX_VERSION ?= "4.1.24"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"