]> code.ossystems Code Review - openembedded-core.git/commitdiff
eglibc: Fix version 2.12 after locale changes
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 28 Jun 2011 12:30:47 +0000 (13:30 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 28 Jun 2011 12:30:47 +0000 (13:30 +0100)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/eglibc/eglibc-initial.inc
meta/recipes-core/eglibc/eglibc-initial_2.13.bb
meta/recipes-core/eglibc/eglibc-locale.inc [new file with mode: 0644]
meta/recipes-core/eglibc/eglibc-locale_2.12.bb [new file with mode: 0644]
meta/recipes-core/eglibc/eglibc-locale_2.13.bb
meta/recipes-core/eglibc/eglibc-package.inc
meta/recipes-core/eglibc/eglibc_2.13.bb

index ce85d99096fcc0e360d11b11329e33b9938f224d..448f73a971d1427535ad4c7100eab22be27772e2 100644 (file)
@@ -52,6 +52,10 @@ do_install () {
        done
 }
 
+do_install_locale() {
+       :
+}
+
 do_siteconfig () {
        :
 }
index b934f5b1bb97059cbc81217b0a884978aa106745..787c762609d6b6f58852b3d4acd12cf9ce0f6f8e 100644 (file)
@@ -1,10 +1,6 @@
 require eglibc_${PV}.bb
 require eglibc-initial.inc
 
-do_install_locale() {
-       :
-}
-
 do_configure_prepend () {
         unset CFLAGS
 }
diff --git a/meta/recipes-core/eglibc/eglibc-locale.inc b/meta/recipes-core/eglibc/eglibc-locale.inc
new file mode 100644 (file)
index 0000000..ed6c099
--- /dev/null
@@ -0,0 +1,58 @@
+INHIBIT_DEFAULT_DEPS = "1"
+LICENSE = "LGPL"
+
+BPN = "eglibc"
+
+do_fetch[noexec] = "1"
+do_unpack[noexec] = "1"
+do_patch[noexec] = "1"
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+# Binary locales are generated at build time if ENABLE_BINARY_LOCALE_GENERATION
+# is set. The idea is to avoid running localedef on the target (at first boot)
+# to decrease initial boot time and avoid localedef being killed by the OOM
+# killer which used to effectively break i18n on machines with < 128MB RAM.
+
+# default to disabled 
+ENABLE_BINARY_LOCALE_GENERATION ?= "0"
+ENABLE_BINARY_LOCALE_GENERATION_pn-eglibc-locale-nativesdk = "0"
+
+#enable locale generation on these arches
+# BINARY_LOCALE_ARCHES is a space separated list of regular expressions
+BINARY_LOCALE_ARCHES ?= "arm.* i[3-6]86 x86_64 powerpc mips"
+
+# set "1" to use cross-localedef for locale generation
+# set "0" for qemu emulation of native localedef for locale generation
+LOCALE_GENERATION_WITH_CROSS-LOCALEDEF = "1"
+
+PR = "r0"
+
+PKGSUFFIX = ""
+PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
+
+PACKAGES = "eglibc-locale localedef${PKGSUFFIX}"
+
+PACKAGES_DYNAMIC = "locale-base-* \
+                    eglibc-gconv-* eglibc-charmap-* eglibc-localedata-* eglibc-binary-localedata-* \
+                    glibc-gconv-*${PKGSUFFIX}  glibc-charmap-*  glibc-localedata-*  glibc-binary-localedata-*"
+
+PROVIDES = "virtual/libc-locale${PKGSUFFIX}"
+
+RPROVIDES_eglibc-locale = "glibc-locale"
+
+FILES_eglibc-gconv = "${libdir}/gconv/*"
+FILES_localedef${PKGSUFFIX} = "${bindir}/localedef"
+
+do_install () {
+       cp -fpPR ${STAGING_INCDIR}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}/* ${D}
+       cp -fpPR ${D}/SUPPORTED ${WORKDIR}
+}
+
+DESCRIPTION_localedef = "eglibc: compile locale definition files"
+
+inherit libc-package
+
+do_install[depends] += "virtual/libc${PKGSUFFIX}:do_populate_sysroot"
+
+BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-core/eglibc/eglibc-locale_2.12.bb b/meta/recipes-core/eglibc/eglibc-locale_2.12.bb
new file mode 100644 (file)
index 0000000..ce6c1d2
--- /dev/null
@@ -0,0 +1 @@
+require eglibc-locale.inc
index ed6c099c6c4a628455ecce99f78442dbd6755139..ce6c1d2320e0435ea4563b03f07a6fe7c4a609cb 100644 (file)
@@ -1,58 +1 @@
-INHIBIT_DEFAULT_DEPS = "1"
-LICENSE = "LGPL"
-
-BPN = "eglibc"
-
-do_fetch[noexec] = "1"
-do_unpack[noexec] = "1"
-do_patch[noexec] = "1"
-do_configure[noexec] = "1"
-do_compile[noexec] = "1"
-
-# Binary locales are generated at build time if ENABLE_BINARY_LOCALE_GENERATION
-# is set. The idea is to avoid running localedef on the target (at first boot)
-# to decrease initial boot time and avoid localedef being killed by the OOM
-# killer which used to effectively break i18n on machines with < 128MB RAM.
-
-# default to disabled 
-ENABLE_BINARY_LOCALE_GENERATION ?= "0"
-ENABLE_BINARY_LOCALE_GENERATION_pn-eglibc-locale-nativesdk = "0"
-
-#enable locale generation on these arches
-# BINARY_LOCALE_ARCHES is a space separated list of regular expressions
-BINARY_LOCALE_ARCHES ?= "arm.* i[3-6]86 x86_64 powerpc mips"
-
-# set "1" to use cross-localedef for locale generation
-# set "0" for qemu emulation of native localedef for locale generation
-LOCALE_GENERATION_WITH_CROSS-LOCALEDEF = "1"
-
-PR = "r0"
-
-PKGSUFFIX = ""
-PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
-
-PACKAGES = "eglibc-locale localedef${PKGSUFFIX}"
-
-PACKAGES_DYNAMIC = "locale-base-* \
-                    eglibc-gconv-* eglibc-charmap-* eglibc-localedata-* eglibc-binary-localedata-* \
-                    glibc-gconv-*${PKGSUFFIX}  glibc-charmap-*  glibc-localedata-*  glibc-binary-localedata-*"
-
-PROVIDES = "virtual/libc-locale${PKGSUFFIX}"
-
-RPROVIDES_eglibc-locale = "glibc-locale"
-
-FILES_eglibc-gconv = "${libdir}/gconv/*"
-FILES_localedef${PKGSUFFIX} = "${bindir}/localedef"
-
-do_install () {
-       cp -fpPR ${STAGING_INCDIR}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}/* ${D}
-       cp -fpPR ${D}/SUPPORTED ${WORKDIR}
-}
-
-DESCRIPTION_localedef = "eglibc: compile locale definition files"
-
-inherit libc-package
-
-do_install[depends] += "virtual/libc${PKGSUFFIX}:do_populate_sysroot"
-
-BBCLASSEXTEND = "nativesdk"
+require eglibc-locale.inc
index fd8fee8031b8f002bfd22e65c96bcf056c0f52f2..8228484815ba9e0860daa18f65ade80e4d86ee2c 100644 (file)
@@ -88,3 +88,15 @@ DESCRIPTION_libsotruss = "Library to support sotruss which traces calls through
 
 inherit libc-common
 
+do_install_locale () {
+       dest=${D}/${includedir}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}
+       install -d ${dest} ${dest}${bindir}
+       cp -fpPR ${D}${base_libdir} ${dest}${base_prefix}
+       cp -fpPR ${D}${libdir} ${dest}${exec_prefix}
+       cp -fpPR ${D}${datadir} ${dest}${exec_prefix}
+       cp -fpPR ${D}${bindir}/localedef ${dest}${bindir}
+       cp -fpPR ${WORKDIR}/SUPPORTED ${dest}
+}
+
+addtask do_install_locale after do_install before do_populate_sysroot
+
index 603d9cdc6259efcb7a413aa527fcc161454b7fa8..3490d2db9fbffea6d57e110ce05762ac742bbc24 100644 (file)
@@ -110,18 +110,6 @@ do_compile () {
        )
 }
 
-do_install_locale () {
-       dest=${D}/${includedir}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}
-       install -d ${dest} ${dest}${bindir}
-       cp -fpPR ${D}${base_libdir} ${dest}${base_prefix}
-       cp -fpPR ${D}${libdir} ${dest}${exec_prefix}
-       cp -fpPR ${D}${datadir} ${dest}${exec_prefix}
-       cp -fpPR ${D}${bindir}/localedef ${dest}${bindir}
-       cp -fpPR ${WORKDIR}/SUPPORTED ${dest}
-}
-
-addtask do_install_locale after do_install before do_populate_sysroot
-
 require eglibc-package.inc
 
 BBCLASSEXTEND = "nativesdk"