]> code.ossystems Code Review - openembedded-core.git/commitdiff
lttng-tools: fix for x32
authorChristopher Larson <chris_larson@mentor.com>
Thu, 1 Dec 2016 02:42:55 +0000 (19:42 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 9 Jan 2017 13:34:31 +0000 (13:34 +0000)
Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-kernel/lttng/lttng-tools/x32.patch [new file with mode: 0644]
meta/recipes-kernel/lttng/lttng-tools_git.bb

diff --git a/meta/recipes-kernel/lttng/lttng-tools/x32.patch b/meta/recipes-kernel/lttng/lttng-tools/x32.patch
new file mode 100644 (file)
index 0000000..b1bb8e4
--- /dev/null
@@ -0,0 +1,16 @@
+Fix build for x32
+
+Upstream-Status: Pending
+Signed-off-by: Christopher Larson <chris_larson@mentor.com>
+
+--- lttng-tools-2.6.0/src/bin/lttng/utils.c~   2015-01-26 18:17:15.000000000 +0100
++++ lttng-tools-2.6.0/src/bin/lttng/utils.c    2015-07-30 19:45:25.632045712 +0200
+@@ -130,7 +130,7 @@
+ #define HAS_FLS_U32
+ #endif
+-#if defined(__x86_64)
++#if defined(__x86_64) && !defined(__ILP32__)
+ static inline
+ unsigned int fls_u64(uint64_t x)
+ {
index 0d2bd005e4b7803337e35d3705a04628efa07dc1..29fd75b21705285f5ffcca6942cf6e560863582c 100644 (file)
@@ -31,6 +31,7 @@ PACKAGECONFIG_remove_libc-musl = "lttng-ust"
 
 SRC_URI = "git://git.lttng.org/lttng-tools.git;branch=stable-2.8 \
            file://0001-Fix-error.h-common-error.h.patch \
+           file://x32.patch \
            file://run-ptest"
 
 S = "${WORKDIR}/git"