]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssh: fix using the original config files in srcdir
authorZheng Junling <zhengjunling@huawei.com>
Wed, 3 Dec 2014 12:38:30 +0000 (12:38 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 31 Dec 2014 10:17:40 +0000 (10:17 +0000)
Currently, we install our own ssh_config and sshd_config into ${S} in
do_compile_append() task. So when finishing compiling, their .out files
are generated by the original files, rather than by our own files.

In most cases, installing "$(CONFIGFILES)" in Makefile will generate .out
files again, and then installing "install-sysconf", which will install
these two files into $(DESTDIR), thus we get what we expect.

However, when parallel installing, "install-sysconf" may be installed
before "$(CONFIGFILES)" sometimes. In this rare case, the .out files
generated in the first time rather than those in the second time will be
installed into $(DESTDIR), and thus we get an unexpect result.

This patch fixes this bug through transfering the installing of our own
files from do_compile_append() into do_configure_prepend().

(From OE-Core rev: 6a60a4ba8d8e529882daa33140c9a2fc08714fb2)

Signed-off-by: Zheng Junling <zhengjunling@huawei.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-connectivity/openssh/openssh_6.6p1.bb

index 047a895aaeb497d9e2b1adef7bea727690794733..e4468c17c39ad4dd1ee989755f6f29254d51feac 100644 (file)
@@ -75,16 +75,13 @@ CACHED_CONFIGUREVARS += "ac_cv_path_PATH_PASSWD_PROG=${bindir}/passwd"
 EXTRA_OECONF_append_libc-uclibc=" --without-pam"
 
 do_configure_prepend () {
+       install -m 0644 ${WORKDIR}/sshd_config ${B}/
+       install -m 0644 ${WORKDIR}/ssh_config ${B}/
        if [ ! -e acinclude.m4 -a -e aclocal.m4 ]; then
                cp aclocal.m4 acinclude.m4
        fi
 }
 
-do_compile_append () {
-       install -m 0644 ${WORKDIR}/sshd_config ${S}/
-       install -m 0644 ${WORKDIR}/ssh_config ${S}/
-}
-
 do_install_append () {
        if [ "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" = "pam" ]; then
                install -D -m 0755 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd