]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add first pass at gypsy.bb file
authorRichard Purdie <richard@openedhand.com>
Fri, 5 Oct 2007 09:26:54 +0000 (09:26 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 5 Oct 2007 09:26:54 +0000 (09:26 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2839 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta-extras/packages/gypsy/files/fixups.patch [new file with mode: 0644]
meta-extras/packages/gypsy/gypsy.inc [new file with mode: 0644]
meta-extras/packages/gypsy/gypsy_svn.bb [new file with mode: 0644]

diff --git a/meta-extras/packages/gypsy/files/fixups.patch b/meta-extras/packages/gypsy/files/fixups.patch
new file mode 100644 (file)
index 0000000..1f64d58
--- /dev/null
@@ -0,0 +1,14 @@
+---
+ docs/reference/Makefile.am |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: gypsy/docs/reference/Makefile.am
+===================================================================
+--- gypsy.orig/docs/reference/Makefile.am      2007-10-04 23:04:44.000000000 +0100
++++ gypsy/docs/reference/Makefile.am   2007-10-04 23:04:53.000000000 +0100
+@@ -82,4 +82,4 @@ include $(top_srcdir)/gtk-doc.make
+ # Other files to distribute
+ # e.g. EXTRA_DIST += version.xml.in
+-EXTRA_DIST +=
++# EXTRA_DIST =
diff --git a/meta-extras/packages/gypsy/gypsy.inc b/meta-extras/packages/gypsy/gypsy.inc
new file mode 100644 (file)
index 0000000..83ab9b1
--- /dev/null
@@ -0,0 +1,12 @@
+DESCRIPTION = "GPS Controlling Daemon"
+LICENSE = "GPL"
+SECTION = "x11"
+DEPENDS = "glib-2.0 dbus"
+
+inherit autotools pkgconfig
+
+do_configure_prepend () {
+       touch ${S}/gtk-doc.make
+}
+
+FILES_${PN} += "/usr/share/dbus-1/services/"
\ No newline at end of file
diff --git a/meta-extras/packages/gypsy/gypsy_svn.bb b/meta-extras/packages/gypsy/gypsy_svn.bb
new file mode 100644 (file)
index 0000000..b24ef26
--- /dev/null
@@ -0,0 +1,9 @@
+require gypsy.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+PV = "0.0+svnr${SRCREV}"
+S = "${WORKDIR}/${PN}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/${PN}/trunk;module=${PN};proto=http \
+           file://fixups.patch;patch=1"
\ No newline at end of file