]> code.ossystems Code Review - openembedded-core.git/commitdiff
packagegroup-core-lsb: add opengl to REQUIRED_DISTRO_FEATURES
authorChristopher Larson <chris_larson@mentor.com>
Wed, 4 Jan 2017 22:57:55 +0000 (15:57 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 5 Jan 2017 13:53:45 +0000 (13:53 +0000)
This group pulls in libglu, which needs virtual/libgl, whose providers require
opengl in DISTRO_FEATURES.

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb

index 734dda1d79b69ea1edf60ce4939ecfb54941213a..3aedf6b7a55fd9f78d0e264281e572b30fcf3003 100644 (file)
@@ -11,6 +11,9 @@ inherit packagegroup distro_features_check
 # The libxt, libxtst and others require x11 in DISTRO_FEATURES
 REQUIRED_DISTRO_FEATURES = "x11"
 
+# libglu needs virtual/libgl, which requires opengl in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES += "opengl"
+
 #
 # We will skip parsing this packagegeoup for non-glibc systems
 #