]> code.ossystems Code Review - openembedded-core.git/commitdiff
pseudo-1.5.1: keep install command directory mode
authoryanjun.zhu <yanjun.zhu@windriver.com>
Mon, 31 Mar 2014 14:41:08 +0000 (22:41 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 31 Mar 2014 16:44:17 +0000 (17:44 +0100)
When install command sets the created directory mode, pseudo will change
the mode of the directory to 0700 incorrectly. Backport patch to fix it.

Signed-off-by: yanjun.zhu <yanjun.zhu@windriver.com>
Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/pseudo/files/pseudo-1.5.1-install-directory-mode.patch [new file with mode: 0644]
meta/recipes-devtools/pseudo/pseudo_1.5.1.bb

diff --git a/meta/recipes-devtools/pseudo/files/pseudo-1.5.1-install-directory-mode.patch b/meta/recipes-devtools/pseudo/files/pseudo-1.5.1-install-directory-mode.patch
new file mode 100644 (file)
index 0000000..e8eaf13
--- /dev/null
@@ -0,0 +1,18 @@
+Upstream-Status: Backport
+
+when install command sets the created directory mode, pseudo will change
+the mode of the directory to 0700 incorrectly.
+
+Signed-off-by: yanjun.zhu <yanjun.zhu@windriver.com>
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+
+--- a/ports/unix/guts/mkdirat.c
++++ b/ports/unix/guts/mkdirat.c
+@@ -25,6 +25,7 @@
+               stat_rc = base_fstatat(dirfd, path, &buf, AT_SYMLINK_NOFOLLOW);
+ #endif
+               if (stat_rc != -1) {
++                      buf.st_mode = PSEUDO_DB_MODE(buf.st_mode, mode);
+                       pseudo_client_op(OP_MKDIR, 0, -1, dirfd, path, &buf);
+               } else {
+                       pseudo_debug(1, "mkdir of %s succeeded, but stat failed: %s\n",
index bc928569df088b7e24c1c5216ce0de5e041cf3b4..215cdb8bcc9e3b45985bdc7d4b9e32b926bc98ab 100644 (file)
@@ -6,6 +6,7 @@ SRC_URI = " \
     http://www.yoctoproject.org/downloads/${BPN}/${BPN}-${PV}.tar.bz2 \
     file://0001-pseudo_has_unload-add-function.patch \
     file://shutdownping.patch \
+    file://pseudo-1.5.1-install-directory-mode.patch \
 "
 
 SRC_URI[md5sum] = "5ec67c7bff5fe68c56de500859c19172"