]> code.ossystems Code Review - openembedded-core.git/commitdiff
strace: 4.9 -> 4.10
authorRobert Yang <liezhi.yang@windriver.com>
Tue, 7 Apr 2015 11:24:22 +0000 (04:24 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 7 Apr 2015 16:32:01 +0000 (17:32 +0100)
Updated patches:
Makefile-ptest.patch
strace-add-configure-options.patch

Fixed:
debugedit: netlink_unix_diag: canonicalization unexpectedly shrank by one character

It was because oe_runmake -C ${TESTDIR} buildtest-TESTS didn't set OS
and ARCH, which caused "-I<foo>//" in gcc options, and would cause
debugedit error.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/strace/strace/Makefile-ptest.patch [moved from meta/recipes-devtools/strace/strace-4.9/Makefile-ptest.patch with 90% similarity]
meta/recipes-devtools/strace/strace/git-version-gen [moved from meta/recipes-devtools/strace/strace-4.9/git-version-gen with 100% similarity]
meta/recipes-devtools/strace/strace/run-ptest [moved from meta/recipes-devtools/strace/strace-4.9/run-ptest with 100% similarity]
meta/recipes-devtools/strace/strace/strace-add-configure-options.patch [moved from meta/recipes-devtools/strace/strace-4.9/strace-add-configure-options.patch with 70% similarity]
meta/recipes-devtools/strace/strace_4.10.bb [moved from meta/recipes-devtools/strace/strace_4.9.bb with 84% similarity]

similarity index 90%
rename from meta/recipes-devtools/strace/strace-4.9/Makefile-ptest.patch
rename to meta/recipes-devtools/strace/strace/Makefile-ptest.patch
index df013102d76632d11a37fda82d3a84dad144b0c4..f3603012f40a59052512bee76f6a23e74f98ec24 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
  2 files changed, 19 insertions(+), 1 deletion(-)
 
 diff --git a/configure.ac b/configure.ac
-index 054f85b..9aec566 100644
+index e73958c..5f0dfee 100644
 --- a/configure.ac
 +++ b/configure.ac
 @@ -6,7 +6,7 @@ AC_INIT([strace],
@@ -23,11 +23,11 @@ index 054f85b..9aec566 100644
  AC_CANONICAL_HOST
  
 diff --git a/tests/Makefile.am b/tests/Makefile.am
-index 922452a..b17837f 100644
+index ff5e136..984bdb6 100644
 --- a/tests/Makefile.am
 +++ b/tests/Makefile.am
-@@ -37,3 +37,21 @@ TEST_LOG_COMPILER = $(srcdir)/run.sh
EXTRA_DIST = init.sh run.sh sigaction.awk $(TESTS)
+@@ -101,3 +101,21 @@ EXTRA_DIST = init.sh run.sh \
           $(TESTS)
  
  CLEANFILES = $(TESTS:=.tmp)
 +
similarity index 70%
rename from meta/recipes-devtools/strace/strace-4.9/strace-add-configure-options.patch
rename to meta/recipes-devtools/strace/strace/strace-add-configure-options.patch
index 15e37bce033c97366baafe0ff2f3cf2f78062b5f..e48e4b31b99c269fb6aa3f2c4c88501c5d5e2932 100644 (file)
@@ -5,24 +5,16 @@ Upstream-Status: Pending
 Signed-off-by: Kai Kang <kai.kang@windriver.com>
 Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
 ---
- configure.ac | 27 ++++++++++++++++++++++++++-
- 1 file changed, 26 insertions(+), 1 deletion(-)
+ configure.ac |   26 ++++++++++++++++++++++++++
+ 1 file changed, 26 insertions(+)
 
 diff --git a/configure.ac b/configure.ac
-index 054f85b..8ed49f1 100644
+index e73958c..9099370 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -238,7 +238,6 @@ AC_CHECK_HEADERS(m4_normalize([
-       poll.h
-       scsi/sg.h
-       stropts.h
--      sys/acl.h
-       sys/asynch.h
-       sys/conf.h
-       sys/epoll.h
-@@ -250,6 +249,18 @@ AC_CHECK_HEADERS(m4_normalize([
-       sys/uio.h
+@@ -270,6 +270,18 @@ AC_CHECK_HEADERS(m4_normalize([
        sys/vfs.h
+       sys/xattr.h
  ]))
 +
 +AC_ARG_ENABLE([acl],
@@ -39,9 +31,9 @@ index 054f85b..8ed49f1 100644
  AC_CHECK_HEADERS([linux/icmp.h linux/in6.h linux/netlink.h linux/if_packet.h],
                   [], [], [#include <stddef.h>
  #include <sys/socket.h>
-@@ -649,6 +660,20 @@ if test "x$st_cv_have___builtin_popcount" = xyes; then
-                 [Define to 1 if the system provides __builtin_popcount function])
+@@ -745,6 +757,20 @@ if test "x$ac_cv_lib_dl_dladdr" = xyes; then
  fi
+ AC_SUBST(dl_LIBS)
  
 +AC_ARG_ENABLE([aio],
 +      [AS_HELP_STRING([--enable-aio], [turn on libaio support])],
@@ -60,6 +52,6 @@ index 054f85b..8ed49f1 100644
  AC_PATH_PROG([PERL], [perl])
  
  dnl stack trace with libunwind
--- 
+--
 1.9.1
 
similarity index 84%
rename from meta/recipes-devtools/strace/strace_4.9.bb
rename to meta/recipes-devtools/strace/strace_4.10.bb
index cce130d58cc08b1193b3fa55da89772829a2619b..416c38756a59a0386de16f656b20ece9a3e7129c 100644 (file)
@@ -11,8 +11,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
            file://run-ptest \
           "
 
-SRC_URI[md5sum] = "885eafadb10f6c60464a266d3929a2a4"
-SRC_URI[sha256sum] = "095bfea5c540b91d297ccac73b21b92fd54a24599fd70395db87ff9eb7fd6f65"
+SRC_URI[md5sum] = "107a5be455493861189e9b57a3a51912"
+SRC_URI[sha256sum] = "e6180d866ef9e76586b96e2ece2bfeeb3aa23f5cc88153f76e9caedd65e40ee2"
 
 inherit autotools ptest
 RDEPENDS_${PN}-ptest += "make coreutils grep gawk"
@@ -23,8 +23,6 @@ PACKAGECONFIG[libaio] = "--enable-aio,--disable-aio,libaio"
 PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
 PACKAGECONFIG[libunwind] = "--with-libunwind, --without-libunwind, libunwind"
 
-export INCLUDES = "-I. -I./linux"
-
 TESTDIR = "tests"
 
 do_configure_prepend() {
@@ -37,7 +35,7 @@ do_install_append() {
 }
 
 do_compile_ptest() {
-       oe_runmake -C ${TESTDIR} buildtest-TESTS
+       oe_runmake -C ${TESTDIR} buildtest-TESTS OS=linux ARCH="${TARGET_ARCH}"
 }
 
 do_install_ptest() {