]> code.ossystems Code Review - openembedded-core.git/commitdiff
attr: Backports to fix exported headers
authorKhem Raj <raj.khem@gmail.com>
Fri, 15 Sep 2017 04:13:28 +0000 (21:13 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Sep 2017 10:07:22 +0000 (11:07 +0100)
Packages which depends on attr headers fail due
to uint32_t not being defined, this needed header
to include sys/types.h

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/attr/attr/0001-Use-stdint-types-consistently.patch [new file with mode: 0644]
meta/recipes-support/attr/attr_2.4.47.bb

diff --git a/meta/recipes-support/attr/attr/0001-Use-stdint-types-consistently.patch b/meta/recipes-support/attr/attr/0001-Use-stdint-types-consistently.patch
new file mode 100644 (file)
index 0000000..dcd6507
--- /dev/null
@@ -0,0 +1,69 @@
+From 37a27b6fd09ecb37097b85e5db74e4f77b80fe0a Mon Sep 17 00:00:00 2001
+From: Felix Janda <felix.janda@posteo.de>
+Date: Tue, 12 Jan 2016 22:20:33 +0100
+Subject: [PATCH] Use stdint types consistently
+
+---
+Upstream-Status: Backport
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+ include/attributes.h | 6 ++++--
+ man/man3/attr_list.3 | 8 ++++----
+ 2 files changed, 8 insertions(+), 6 deletions(-)
+
+Index: attr-2.4.47/include/attributes.h
+===================================================================
+--- attr-2.4.47.orig/include/attributes.h
++++ attr-2.4.47/include/attributes.h
+@@ -22,6 +22,7 @@
+ extern "C" {
+ #endif
++#include <stdint.h>
+ /*
+  *    An almost-IRIX-compatible extended attributes API
+  *    (the IRIX attribute "list" operation is missing, added ATTR_SECURE).
+@@ -69,7 +70,7 @@ typedef struct attrlist {
+  * al_offset[i] entry points to.
+  */
+ typedef struct attrlist_ent { /* data from attr_list() */
+-      u_int32_t       a_valuelen;     /* number bytes in value of attr */
++      uint32_t        a_valuelen;     /* number bytes in value of attr */
+       char            a_name[1];      /* attr name (NULL terminated) */
+ } attrlist_ent_t;
+@@ -90,7 +91,7 @@ typedef struct attrlist_ent {        /* data fr
+  * operation on a cursor is to bzero() it.
+  */
+ typedef struct attrlist_cursor {
+-      u_int32_t       opaque[4];      /* an opaque cookie */
++      uint32_t        opaque[4];      /* an opaque cookie */
+ } attrlist_cursor_t;
+ /*
+Index: attr-2.4.47/man/man3/attr_list.3
+===================================================================
+--- attr-2.4.47.orig/man/man3/attr_list.3
++++ attr-2.4.47/man/man3/attr_list.3
+@@ -72,9 +72,9 @@ The contents of an \f4attrlist_t\fP stru
+ .nf
+ .ft 4
+ .ta 9n 22n
+-__int32_t al_count; /\(** number of entries in attrlist \(**/
+-__int32_t al_more; /\(** T/F: more attrs (do syscall again) \(**/
+-__int32_t al_offset[1]; /\(** byte offsets of attrs [var-sized] \(**/
++int32_t al_count; /\(** number of entries in attrlist \(**/
++int32_t al_more; /\(** T/F: more attrs (do syscall again) \(**/
++int32_t al_offset[1]; /\(** byte offsets of attrs [var-sized] \(**/
+ .ft 1
+ .fi
+ .RE
+@@ -113,7 +113,7 @@ include the following members:
+ .nf
+ .ft 4
+ .ta 9n 22n
+-u_int32_t a_valuelen; /\(** number bytes in value of attr \(**/
++uint32_t a_valuelen; /\(** number bytes in value of attr \(**/
+ char a_name[]; /\(** attr name (NULL terminated) \(**/
+ .ft 1
+ .fi
index 2dada7a1fc0b6807c1992d8ec7e9367f9ce3d4ba..fc88bef830b1a92b85a0ac5b395791bc64a6f28e 100644 (file)
@@ -6,6 +6,7 @@ SRC_URI += "file://attr-Missing-configure.ac.patch \
             file://dont-use-decl-macros.patch \
             file://Remove-the-section-2-man-pages.patch \
             file://Remove-the-attr.5-man-page-moved-to-man-pages.patch \
+            file://0001-Use-stdint-types-consistently.patch \
            "
 
 SRC_URI[md5sum] = "84f58dec00b60f2dc8fd1c9709291cc7"