]> code.ossystems Code Review - openembedded-core.git/commitdiff
libiconv: Extend to nativesdk and support non-linux targets
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 20 Aug 2013 17:19:29 +0000 (17:19 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Aug 2013 17:30:05 +0000 (18:30 +0100)
This library is currently only available when targeting non-libc. This patch
also makes it available when targetting non-linux since it is likely of use
then.

It also adds a BBCLASSEXTEND for nativesdk since again, it can be useful
in that context.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libiconv/libiconv_1.14.bb

index b1d2612d09ecd98e5e49bfa4629939700eca382e..470900bca7c6c400247e3c5b1ddc7b395f0e346a 100644 (file)
@@ -22,6 +22,8 @@ S = "${WORKDIR}/libiconv-${PV}"
 inherit autotools pkgconfig gettext
 
 python __anonymous() {
+    if d.getVar("TARGET_OS", True) != "linux":
+        return
     if d.getVar("TCLIBC", True) == "eglibc":
         raise bb.parse.SkipPackage("libiconv is provided for use with uClibc only - eglibc already provides iconv")
 }
@@ -44,3 +46,5 @@ do_install_append () {
        rm -rf ${D}${libdir}/preloadable_libiconv.so
        rm -rf ${D}${libdir}/charset.alias
 }
+
+BBCLASSEXTEND = "nativesdk"