]> code.ossystems Code Review - openembedded-core.git/commitdiff
chkconfig: obey sysconfdir, base_libdir
authorChristopher Larson <chris_larson@mentor.com>
Sat, 29 Dec 2012 05:19:26 +0000 (22:19 -0700)
committerSaul Wold <sgw@linux.intel.com>
Sat, 5 Jan 2013 06:12:05 +0000 (22:12 -0800)
Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb

index 7915594c6e5f7ee9cbbba5fd609f7fb9999c5d26..df9b193ac2401b57ad635e3eb058b34ba06db8f4 100644 (file)
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
 
 DEPENDS = "libnewt popt"
 
-PR = "r5"
+PR = "r6"
 
 SRC_URI = "http://fedorahosted.org/releases/c/h/chkconfig/${BPN}-${PV}.tar.bz2"
 
@@ -31,6 +31,12 @@ EXTRA_OEMAKE = "\
     'MANDIR=${mandir}' \
 "
 
+do_unpack[postfuncs] += "obey_variables"
+do_unpack[vardeps] += "obey_variables"
+obey_variables () {
+       sed -i -e 's,/etc,${sysconfdir},; s,/lib/systemd,${base_libdir}/systemd,' leveldb.h
+}
+
 do_install() {
        oe_runmake 'DESTDIR=${D}' 'INSTALLNLSDIR=${D}${datadir}/locale' install
        mkdir -p ${D}${sysconfdir}/chkconfig.d