]> code.ossystems Code Review - openembedded-core.git/commitdiff
pth: Fix case where ${B} != ${S}
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Mar 2013 14:25:18 +0000 (14:25 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Mar 2013 17:04:56 +0000 (17:04 +0000)
Ensure the autotools commands are executed in ${S} to allow out of tree
builds to work.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/pth/pth_2.0.7.bb

index fc9ed16aca12b37ebbb009dad77d7fa985567d29..8cbab7d8227b5ed33b089be01dadc7ff89237eb4 100644 (file)
@@ -23,7 +23,7 @@ PARALLEL_MAKE=""
 inherit autotools binconfig pkgconfig
 
 do_configure() {
-       gnu-configize
-       autoconf
+       ( cd ${S}; gnu-configize )
+       ( cd ${S}; autoconf )
        oe_runconf
 }