]> code.ossystems Code Review - openembedded-core.git/commitdiff
linuxdoc-tools-native: Fix build error with txt documentation
authorScott Garman <scott.a.garman@intel.com>
Sat, 5 Mar 2011 14:20:53 +0000 (14:20 +0000)
committerKhem Raj <raj.khem@gmail.com>
Sat, 5 Mar 2011 17:44:30 +0000 (09:44 -0800)
Disable building txt documentation. This is a temporary workaround,
as I have found an Ubuntu 10.10 system which throws errors during
building this that I'd like to ultimately fix. The error manifests
itself from the end of LinuxDocTools.pm with the following messages
during do_install:

| - Building txt docs
| Processing file ./guide
| troff: fatal error: can't find macro file s
|  fmt_txt::postASP: Empty output file, error when calling groff. Aborting...

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native/disable_txt_doc.patch [new file with mode: 0644]
meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native_0.9.66.bb

diff --git a/meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native/disable_txt_doc.patch b/meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native/disable_txt_doc.patch
new file mode 100644 (file)
index 0000000..17c7670
--- /dev/null
@@ -0,0 +1,32 @@
+Disable building txt documentation. This is a temporary workaround,
+as I have found an Ubuntu 10.10 system which throws errors during
+building this that I'd like to ultimately fix. The error manifests
+itself from the end of LinuxDocTools.pm with the following messages
+during do_install:
+
+| - Building txt docs
+| Processing file ./guide
+| troff: fatal error: can't find macro file s
+|  fmt_txt::postASP: Empty output file, error when calling groff. Aborting...
+
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
+diff -urN linuxdoc-tools-0.9.66.orig//doc/Makedoc.sh linuxdoc-tools-0.9.66/doc/Makedoc.sh
+--- linuxdoc-tools-0.9.66.orig//doc/Makedoc.sh 2009-11-09 11:58:25.000000000 -0800
++++ linuxdoc-tools-0.9.66/doc/Makedoc.sh       2011-03-04 17:37:24.788923998 -0800
+@@ -40,11 +40,11 @@
+ chmod u+x $TMPDIR/linuxdoc
+-if [ -n "`which groff`" ]; then
+-      ln -s $TMPDIR/linuxdoc $TMPDIR/sgml2txt
+-      echo "- Building txt docs" >&2
+-      $TMPDIR/sgml2txt -b 1 ./guide
+-fi
++#if [ -n "`which groff`" ]; then
++#     ln -s $TMPDIR/linuxdoc $TMPDIR/sgml2txt
++#     echo "- Building txt docs" >&2
++#     $TMPDIR/sgml2txt -b 1 ./guide
++#fi
+ if [ -n "`which latex`" ]; then
+       ln -s $TMPDIR/linuxdoc $TMPDIR/sgml2latex
index ed45ad929f4b2831b7c4523f9ae258e98e460458..fbe9219adb2419825f5109f817db3dea17dd8206 100644 (file)
@@ -6,10 +6,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5fbccc46cff2379505ca4e09c7d6ccfe"
 
 DEPENDS = "openjade-native"
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/l/linuxdoc-tools/linuxdoc-tools_${PV}.tar.gz \
            file://disable_sgml2rtf.patch \
+           file://disable_txt_doc.patch \
            file://disable_tex_doc.patch \
            file://disable_dvips_doc.patch"