]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-pbr: Move src uri checksums out of .inc file
authorKhem Raj <raj.khem@gmail.com>
Sun, 13 Jan 2019 16:03:28 +0000 (08:03 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 14 Jan 2019 11:21:58 +0000 (11:21 +0000)
python2 version of pbr is in meta-python and uses the same inc file but
is not updated synchronously, which ends up breaking it, either we move
py2 version into OE-core as well and then ensure that both recipes are
updated atomically, or we move the checksums into recipe files

Fixes errors like
http://errors.yoctoproject.org/Errors/Details/216253/

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python-pbr.inc
meta/recipes-devtools/python/python3-pbr_5.1.1.bb

index bfe3030b0734f959c29eeb0f7c6973a933b506a7..0e64501c32b238a4ab6a74d36a3a2c71e528f3ef 100644 (file)
@@ -5,9 +5,6 @@ SECTION = "devel/python"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
 
-SRC_URI[md5sum] = "dbc94417a8ff0432d6244501a7f1bd49"
-SRC_URI[sha256sum] = "f59d71442f9ece3dffc17bc36575768e1ee9967756e6b6535f0ee1f0054c3d68"
-
 inherit pypi
 
 RDEPENDS_${PN} += "${PYTHON_PN}-pip"
index 97e7361b169f1c042fbdffcb5c0956974cc777be..95d3d2bd4f3cdb5ff3e048e911714bd9b3c7e75a 100644 (file)
@@ -1,2 +1,5 @@
 inherit setuptools3
 require python-pbr.inc
+SRC_URI[md5sum] = "dbc94417a8ff0432d6244501a7f1bd49"
+SRC_URI[sha256sum] = "f59d71442f9ece3dffc17bc36575768e1ee9967756e6b6535f0ee1f0054c3d68"
+