]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxcrypt: Upgrade to 4.0.1
authorKhem Raj <raj.khem@gmail.com>
Thu, 17 May 2018 16:11:34 +0000 (09:11 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 29 May 2018 20:06:00 +0000 (21:06 +0100)
Minor release primary fixes are
* get it building with gcc8
* Fixes for riscv64

drop local gcc8 support patch which is not needed now

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/libxcrypt/libxcrypt/0001-disable-format-truncation-warning-with-gcc-8.patch [deleted file]
meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb [moved from meta/recipes-core/libxcrypt/libxcrypt_4.0.0.bb with 88% similarity]

diff --git a/meta/recipes-core/libxcrypt/libxcrypt/0001-disable-format-truncation-warning-with-gcc-8.patch b/meta/recipes-core/libxcrypt/libxcrypt/0001-disable-format-truncation-warning-with-gcc-8.patch
deleted file mode 100644 (file)
index 654eae6..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-From c8c5908611e44a649489e8d217528fedc4864e14 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 10 May 2018 13:32:20 -0700
-Subject: [PATCH] disable format-truncation warning with gcc-8
-
-Upstream-Status: Pending
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- crypt-sunmd5.c | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/crypt-sunmd5.c b/crypt-sunmd5.c
-index 4c85b7f..3e838cd 100644
---- a/crypt-sunmd5.c
-+++ b/crypt-sunmd5.c
-@@ -151,6 +151,11 @@ getrounds (const char *s)
-   return ((uint32_t)val);
- }
-+#pragma GCC diagnostic push
-+#if defined(__GNUC__) && (__GNUC__ >= 8)
-+#pragma GCC diagnostic ignored "-Wformat-truncation"
-+#endif
-+
- void
- gensalt_sunmd5_rn (unsigned long count,
-                    const uint8_t *rbytes, size_t nrbytes,
-@@ -189,6 +194,7 @@ gensalt_sunmd5_rn (unsigned long count,
-             "$" CRYPT_ALGNAME "," ROUNDS "%u$%s$",
-             (unsigned int)count, rndstr);
- }
-+#pragma GCC diagnostic pop
- void
- crypt_sunmd5_rn (const char *phrase, const char *setting,
similarity index 88%
rename from meta/recipes-core/libxcrypt/libxcrypt_4.0.0.bb
rename to meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb
index 8cc5edac492db1b800269b5dc707cd1f37638ffa..6ed67a67611ac28f617ed5278850cb6819c12f90 100644 (file)
@@ -9,11 +9,10 @@ LIC_FILES_CHKSUM ?= "file://LICENSING;md5=d1cc18f512ded3bd6000f3729f31be08 \
 
 inherit autotools
 
-SRCREV ?= "215b32aa4e0b255c3356a96bd6d257661bad73ca"
+SRCREV ?= "089479bb24acd168613757a6f12d63caa95416b4"
 SRCBRANCH ?= "master"
 
 SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH} \
-           file://0001-disable-format-truncation-warning-with-gcc-8.patch \
            "
 
 PROVIDES = "virtual/crypt"