]> code.ossystems Code Review - openembedded-core.git/commitdiff
bootchart2: Don't compile python modules
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 12 Oct 2021 11:51:51 +0000 (12:51 +0100)
committerAnuj Mittal <anuj.mittal@intel.com>
Mon, 1 Nov 2021 15:18:14 +0000 (23:18 +0800)
"make install" may attempt to compile the python modules but it uses the host python
and host paths which means the binaries are not reproducbile. Make things consistent.
If anyone needs compiling, it will beed to be fixed to be cross compile compatible.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 1189f95e05c80286e009e1ab46a603ee5b7ca239)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb

index f6a77b46060cbe31417b1269f8f00136d76ff65e..d5beaecd0ed94cf5156cbc77e1cc5ba1ba574767 100644 (file)
@@ -99,6 +99,10 @@ SRC_URI = "git://github.com/xrmx/bootchart.git \
 S = "${WORKDIR}/git"
 SRCREV = "868a2afab9da34f32c007d773b77253c93104636"
 
+# remove at next version upgrade or when output changes
+PR = "r1"
+HASHEQUIV_HASH_VERSION .= ".1"
+
 inherit systemd update-rc.d python3native update-alternatives
 
 ALTERNATIVE_${PN} = "bootchartd"
@@ -131,7 +135,7 @@ do_install () {
     export PKGLIBDIR="${base_libdir}/bootchart"
     export SYSTEMD_UNIT_DIR="${systemd_unitdir}/system"
 
-    oe_runmake install
+    oe_runmake install NO_PYTHON_COMPILE=1
     install -d ${D}${sysconfdir}/init.d
     install -m 0755 ${WORKDIR}/bootchartd_stop.sh ${D}${sysconfdir}/init.d