]> code.ossystems Code Review - openembedded-core.git/commitdiff
build-appliance-image: use 'lnr' instead of 'ln -sr'
authorMing Liu <peter.x.liu@external.atlascopco.com>
Fri, 20 May 2016 20:14:20 +0000 (22:14 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 21 May 2016 21:21:30 +0000 (22:21 +0100)
For portability, not all hosts are running sufficiently new coreutils.

Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/images/build-appliance-image_14.0.0.bb

index 2a1a56b6177726ee5c04177411e03501cbe1057c..d6de67c8c8c8036a68bf8e2f41287ac480b48020 100644 (file)
@@ -54,7 +54,7 @@ fakeroot do_populate_poky_src () {
        cp ${WORKDIR}/README_VirtualBox_Guest_Additions.txt ${IMAGE_ROOTFS}/home/builder/
 
        # Create a symlink, needed for out-of-tree kernel modules build
-       ln -snr ${IMAGE_ROOTFS}${KERNEL_SRC_PATH} ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build
+       lnr ${IMAGE_ROOTFS}${KERNEL_SRC_PATH} ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build
 
        echo "/usr/bin" > ${IMAGE_ROOTFS}/home/builder/poky/build/pseudodone
        echo "INHERIT += \"rm_work\"" >> ${IMAGE_ROOTFS}/home/builder/poky/build/conf/auto.conf
@@ -84,7 +84,7 @@ fakeroot do_populate_poky_src () {
        echo "builder ALL=(ALL) NOPASSWD: ALL" >> ${IMAGE_ROOTFS}/etc/sudoers
 
        # Load tap/tun at startup
-       ln -sr ${IMAGE_ROOTFS}/usr/sbin/iptables ${IMAGE_ROOTFS}/sbin/iptables
+       lnr ${IMAGE_ROOTFS}/usr/sbin/iptables ${IMAGE_ROOTFS}/sbin/iptables
        echo "tun" >> ${IMAGE_ROOTFS}/etc/modules
 
        # Use Clearlooks GTK+ theme