]> code.ossystems Code Review - openembedded-core.git/commitdiff
eglibc-package.bbclass: Fix unintended code changes
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 30 Jun 2011 15:41:49 +0000 (16:41 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 30 Jun 2011 15:41:49 +0000 (16:41 +0100)
Commit 477ede7472db0bacd5daacb96e97f849d1be84ee accidentally reverted
some code changes it shouldn't have done leading to continued eglibc
packaging issues. This patch corrects that damage.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/eglibc/eglibc-package.inc
meta/recipes-core/eglibc/eglibc_2.13.bb

index 8228484815ba9e0860daa18f65ade80e4d86ee2c..831835612ec5a4b6d006209247f59c5a389ced98 100644 (file)
@@ -90,13 +90,21 @@ inherit libc-common
 
 do_install_locale () {
        dest=${D}/${includedir}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}
-       install -d ${dest} ${dest}${bindir}
-       cp -fpPR ${D}${base_libdir} ${dest}${base_prefix}
-       cp -fpPR ${D}${libdir} ${dest}${exec_prefix}
-       cp -fpPR ${D}${datadir} ${dest}${exec_prefix}
-       cp -fpPR ${D}${bindir}/localedef ${dest}${bindir}
+       install -d ${dest}${base_libdir} ${dest}${bindir} ${dest}${libdir} ${dest}${datadir}
+       cp -fpPR ${D}${base_libdir}/* ${dest}${base_libdir}
+       cp -fpP ${D}${bindir}/localedef ${dest}${bindir}
+        mv ${D}${libdir}/gconv ${dest}${libdir}
+       cp -fpPR ${D}${libdir}/* ${dest}${libdir}
+        mv ${D}${datadir}/i18n ${dest}${datadir}
+       cp -fpPR ${D}${datadir}/* ${dest}${datadir}
        cp -fpPR ${WORKDIR}/SUPPORTED ${dest}
 }
 
 addtask do_install_locale after do_install before do_populate_sysroot
 
+PACKAGE_PREPROCESS_FUNCS += "eglibc_package_preprocess"
+
+eglibc_package_preprocess () {
+       rm -rf ${PKGD}/${includedir}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}
+}
+
index 50880496f64fcc8bba6358fbe783ef33d435e485..7986131809b7868921d8ba26ba6299b0d06733bc 100644 (file)
@@ -4,7 +4,7 @@ SRCREV = "14157"
 
 DEPENDS += "gperf-native"
 FILESPATHPKG =. "eglibc-svn:"
-PR = "r4"
+PR = "r5"
 PR_append = "+svnr${SRCPV}"
 
 EGLIBC_BRANCH="eglibc-2_13"