]> code.ossystems Code Review - openembedded-core.git/commitdiff
nspr: fix script conflict for multilib
authorZhixiong Chi <zhixiong.chi@windriver.com>
Mon, 13 Aug 2018 07:04:24 +0000 (00:04 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 14 Aug 2018 10:36:22 +0000 (11:36 +0100)
Stop the nspr-config scripts conflicting in a multilib case.

Signed-off-by: Zhixiong Chi <zhixiong.chi@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/nspr/nspr_4.19.bb

index b43c78081d7ecca2b99769f6348b9c34f1b1bbd8..b5264be2a073d6b13853bd1abdc6b595f119ddf4 100644 (file)
@@ -149,7 +149,9 @@ TESTS = " \
     xnotify \
     zerolen"
 
-inherit autotools
+inherit autotools multilib_script
+
+MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/nspr-config"
 
 PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
 PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"