]> code.ossystems Code Review - openembedded-core.git/commitdiff
gdb: 7.7.1 -> 7.8.1
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 4 Nov 2014 11:39:08 +0000 (11:39 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 9 Nov 2014 10:17:02 +0000 (10:17 +0000)
Drop patch merged upstream.

Also drop old arm/thumb patch which breaks the compile on arm. We've
had this since 2010 (or longer) and the issue has likely been fixed
upstream by now. If not someone with more knowledge will need to
figure out the fix against the current codebase.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/gdb/gdb-7.8.1.inc [moved from meta/recipes-devtools/gdb/gdb-7.7.1.inc with 70% similarity]
meta/recipes-devtools/gdb/gdb-cross-canadian_7.8.1.bb [moved from meta/recipes-devtools/gdb/gdb-cross-canadian_7.7.1.bb with 100% similarity]
meta/recipes-devtools/gdb/gdb-cross_7.8.1.bb [moved from meta/recipes-devtools/gdb/gdb-cross_7.7.1.bb with 100% similarity]
meta/recipes-devtools/gdb/gdb.inc
meta/recipes-devtools/gdb/gdb/include_asm_ptrace.patch [deleted file]
meta/recipes-devtools/gdb/gdb/kill_arm_map_symbols.patch [deleted file]
meta/recipes-devtools/gdb/gdb_7.8.1.bb [moved from meta/recipes-devtools/gdb/gdb_7.7.1.bb with 100% similarity]

similarity index 70%
rename from meta/recipes-devtools/gdb/gdb-7.7.1.inc
rename to meta/recipes-devtools/gdb/gdb-7.8.1.inc
index aa16d5a09f592907668bc93a2b62f0943028a2ae..6fa13bc58264587e75661f2cdbfb73d2a5b5969f 100644 (file)
@@ -6,5 +6,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
 
 S = "${WORKDIR}/${BPN}-${PV}"
 
-SRC_URI[md5sum] = "45b07b53d81832d32ccd4829465d4886"
-SRC_URI[sha256sum] = "eefadb9831e3695d1eaef34e98b8f1fb441df6fe5071317ea49c6bd6ba213eff"
+SRC_URI[md5sum] = "997492cc3475c96f35ecc8775248c9b1"
+SRC_URI[sha256sum] = "d7a923d876ecfa1cec4c1c79c014c9d8e58783a25855a95cf260275f61990647"
+
index 7b3e59af624a1b0a3ba5b289bf218ee4391ec292..2c95e03b1b6fd3809d7d59ff443aa21b108ae50d 100644 (file)
@@ -2,10 +2,8 @@ require gdb-common.inc
 
 inherit gettext
 
-SRC_URI += "file://kill_arm_map_symbols.patch \
-            file://gdbserver-cflags-last.diff;striplevel=0 \
+SRC_URI += "file://gdbserver-cflags-last.diff;striplevel=0 \
             file://renesas-sh-native-support.patch \
-            file://include_asm_ptrace.patch \
            "
 #LDFLAGS_append = " -s"
 #export CFLAGS_append=" -L${STAGING_LIBDIR}"
diff --git a/meta/recipes-devtools/gdb/gdb/include_asm_ptrace.patch b/meta/recipes-devtools/gdb/gdb/include_asm_ptrace.patch
deleted file mode 100644 (file)
index 85e0147..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-gdb: include asm/ptrace.h in two aarch64 source files
-
-Both sys/ptrace.h and asm/ptrace.h need to be included.
-
-Upstream-Status: Pending
-
-Signed-off-by: joe.slater@windriver.com
-
-
---- a/gdb/aarch64-linux-nat.c
-+++ b/gdb/aarch64-linux-nat.c
-@@ -32,6 +32,8 @@
- #include "elf/common.h"
- #include <sys/ptrace.h>
-+#include <asm/ptrace.h>
-+
- #include <sys/utsname.h>
- #include "gregset.h"
---- a/gdb/gdbserver/linux-aarch64-low.c
-+++ b/gdb/gdbserver/linux-aarch64-low.c
-@@ -26,6 +26,7 @@
- #include <signal.h>
- #include <sys/user.h>
- #include <sys/ptrace.h>
-+#include <asm/ptrace.h>
- #include <sys/uio.h>
- #include "gdb_proc_service.h"
diff --git a/meta/recipes-devtools/gdb/gdb/kill_arm_map_symbols.patch b/meta/recipes-devtools/gdb/gdb/kill_arm_map_symbols.patch
deleted file mode 100644 (file)
index 9fc45b9..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-Upstream-Status: Inappropriate [embedded specific]
-
-Index: gdb-7.3/gdb/arm-tdep.c
-===================================================================
---- gdb-7.3.orig/gdb/arm-tdep.c        2011-05-17 14:27:01.000000000 -0700
-+++ gdb-7.3/gdb/arm-tdep.c     2011-08-05 22:29:58.784201850 -0700
-@@ -7806,6 +7806,19 @@
- static void
- arm_elf_make_msymbol_special(asymbol *sym, struct minimal_symbol *msym)
- {
-+
-+    /* FIXME: We want gdb to ignore the ARM ELF mapping symbols when
-+      displaying disassembly so we use this horrible hack here to
-+      artifically set their address to the highest possible value.
-+      This is wrong of course, and it prevents the symbols from being
-+      used for their intended purpose - to distinguish between ARM
-+      and THUMB code.  So we ought to find a better way to do this.  */
-+    if (bfd_asymbol_name (sym)
-+      && bfd_asymbol_name (sym)[0] == '$'
-+      && bfd_asymbol_name (sym)[1] != 0
-+      && bfd_asymbol_name (sym)[2] == 0)
-+      SYMBOL_VALUE_ADDRESS(msym) = (CORE_ADDR) 0x7ffffffc;
-+
-   if (ARM_SYM_BRANCH_TYPE (&((elf_symbol_type *)sym)->internal_elf_sym)
-       == ST_BRANCH_TO_THUMB)
-     MSYMBOL_SET_SPECIAL (msym);