]> code.ossystems Code Review - openembedded-core.git/commitdiff
uclibc: Only need to install to staging, not cross as well (after cross linkage changes)
authorRichard Purdie <richard@openedhand.com>
Mon, 12 Nov 2007 11:14:24 +0000 (11:14 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 12 Nov 2007 11:14:24 +0000 (11:14 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3120 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/uclibc/uclibc-initial_0.9.29.bb
meta/packages/uclibc/uclibc.inc

index 840acafeaca4725a038bf96121294c6aca061e6e..aa42fa3d19ef180b7ffbe812680066da8f8fb753 100644 (file)
@@ -9,18 +9,14 @@ PACKAGES = ""
 
 do_stage() {
        # Install initial headers into the cross dir
-       make PREFIX= DEVEL_PREFIX=${UCLIBC_PREFIX}/ \
-               RUNTIME_PREFIX=${UCLIBC_PREFIX}/ \
+       make PREFIX= DEVEL_PREFIX=${UCLIBC_STAGE_PREFIX}/ \
+               RUNTIME_PREFIX=${UCLIBC_STAGE_PREFIX}/ \
                pregen install_dev
 
-       mkdir -p ${CROSS_DIR}/${TARGET_SYS}
-       mkdir -p ${CROSS_DIR}/${TARGET_SYS}/include
-       mkdir -p ${CROSS_DIR}/${TARGET_SYS}/lib
        ln -sf include ${CROSS_DIR}/${TARGET_SYS}/sys-include
-       rm -rf ${CROSS_DIR}/${TARGET_SYS}/${prefix}
 
        # This conflicts with the c++ version of this header
-       rm -f ${UCLIBC_PREFIX}/include/bits/atomicity.h
+       rm -f ${UCLIBC_STAGE_PREFIX}/include/bits/atomicity.h
 }
 
 do_install() {
index 7fb8e5cf28c802a3264df413935066bf8459e62d..0a22ae0271f9dcd836e7615aa1026de930c58d30 100644 (file)
@@ -66,8 +66,7 @@ UCLIBC_LOCALE_URI_arm = "http://openembedded.org/dl/uclibc-locale/${UCLIBC_LOCAL
 SRC_URI = "${@['${UCLIBC_LOCALE_URI}', ''][bb.data.getVar('USE_NLS', d, 1) != 'yes']} \
           file://uClibc.config"
 
-UCLIBC_PREFIX = "${CROSS_DIR}/${TARGET_SYS}"
-UCLIBC_STAGE_PREFIX = "${STAGING_DIR}/${HOST_SYS}"
+UCLIBC_STAGE_PREFIX = "${STAGING_DIR_HOST}${layout_prefix}"
 
 # do_stage barfs on a CC with whitepspace, therefore put the 'HOST_CC_ARCH' in
 # the CFLAGS (for when building the utils).
@@ -145,34 +144,14 @@ do_configure() {
 }
 
 do_stage() {
-       # Install into the cross dir (this MUST be done first because we
-       # will install crt1.o in the install_dev stage and gcc needs it)
-       oe_runmake PREFIX= DEVEL_PREFIX=${UCLIBC_PREFIX}/ \
-               RUNTIME_PREFIX=${UCLIBC_PREFIX}/ \
+       oe_runmake PREFIX= DEVEL_PREFIX=${UCLIBC_STAGE_PREFIX}/ \
+               RUNTIME_PREFIX=${UCLIBC_STAGE_PREFIX}/ \
                install_dev install_runtime
 
        oe_runmake utils
-       oe_runmake PREFIX= DEVEL_PREFIX=${UCLIBC_PREFIX}/ \
-               RUNTIME_PREFIX=${UCLIBC_PREFIX}/ \
-               install_utils
-
-       # We don't really need this
-       rm -f ${UCLIBC_PREFIX}/include/.cvsignore
-
-       # Fixup shared lib symlinks
-       ( cd ${UCLIBC_PREFIX}/lib
-               for f in c crypt dl m nsl pthread resolv thread_db util; do
-                       ln -sf lib${f}.so.? lib${f}.so
-               done
-       )
-
-       # This conflicts with the c++ version of this header
-       rm -f ${UCLIBC_PREFIX}/include/bits/atomicity.h
-
-       # Install into the staging dir
        oe_runmake PREFIX= DEVEL_PREFIX=${UCLIBC_STAGE_PREFIX}/ \
                RUNTIME_PREFIX=${UCLIBC_STAGE_PREFIX}/ \
-               install_dev install_runtime install_utils
+               install_utils
 
        # We don't really need this
        rm -f ${UCLIBC_STAGE_PREFIX}/include/.cvsignore