]> code.ossystems Code Review - openembedded-core.git/commitdiff
go-runtime_1.9: pass BUILD_ flags to cgo for host-side build
authorMatt Madison <matt@madison.systems>
Sat, 21 Apr 2018 13:19:37 +0000 (06:19 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 23 Apr 2018 10:15:06 +0000 (11:15 +0100)
When running the make.bash script to build the host-side
tools, make sure that cgo is using CFLAGS and LDFLAGS for
the build host, rather than those for the target.

[YOCTO #12704]

Signed-off-by: Matt Madison <matt@madison.systems>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/go/go-runtime_1.9.bb

index a99cc30f63e97a41b760eb925d832efca5cf9bda..d5279ea89702bbdea081a062b1b02ae355dcae6e 100644 (file)
@@ -11,7 +11,7 @@ do_compile() {
        export CC=$BUILD_CC
 
        cd src
-       ./make.bash --host-only
+       CGO_CFLAGS="${BUILD_CFLAGS}" CGO_LDFLAGS="${BUILD_LDFLAGS}" ./make.bash --host-only
        cp ${B}/pkg/tool/${BUILD_GOTUPLE}/go_bootstrap ${B}
        rm -rf ${B}/pkg/${TARGET_GOTUPLE}
        ./make.bash --target-only