]> code.ossystems Code Review - openembedded-core.git/commitdiff
os-release: move to nonarch_libdir
authorDan McGregor <dan.mcgregor@usask.ca>
Thu, 18 Oct 2018 15:24:23 +0000 (09:24 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 7 Nov 2018 21:31:16 +0000 (21:31 +0000)
Even on multilib systems, /usr/lib is where systemd expects the
os-release file to live.

(From OE-Core rev: b7b476efee8c959a0227905e40bd9b5ef493632d)

Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-core/os-release/os-release.bb

index bf4f815a10d00bff4e7f41f1d8f9dbc35a0d86de..7f3d9cba00c97c5f557bf8bf51d55145cdba2cd8 100644 (file)
@@ -42,9 +42,9 @@ python do_compile () {
 do_compile[vardeps] += "${OS_RELEASE_FIELDS}"
 
 do_install () {
-    install -d ${D}${libdir} ${D}${sysconfdir}
-    install -m 0644 os-release ${D}${libdir}/
-    lnr ${D}${libdir}/os-release ${D}${sysconfdir}/os-release
+    install -d ${D}${nonarch_libdir} ${D}${sysconfdir}
+    install -m 0644 os-release ${D}${nonarch_libdir}/
+    lnr ${D}${nonarch_libdir}/os-release ${D}${sysconfdir}/os-release
 }
 
-FILES_${PN} += "${libdir}/os-release"
+FILES_${PN} += "${nonarch_libdir}/os-release"