]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel: set COMPATIBLE_HOST to *-linux
authorRoss Burton <ross@burtonini.com>
Fri, 11 Dec 2020 16:09:22 +0000 (16:09 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Dec 2020 08:25:10 +0000 (08:25 +0000)
The target system triple contains whether the target is Linux or not,
so use it to avoid situations where you can attempt to build a kernel
for systems which don't support Linux.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/kernel.bbclass
meta/recipes-kernel/linux/linux-dummy.bb

index 1a444efabf1b51941a4b2027b9e5ba48c121d711..2f1006ddf06301404ace4f11faf5a7b1072d461a 100644 (file)
@@ -1,5 +1,7 @@
 inherit linux-kernel-base kernel-module-split
 
+COMPATIBLE_HOST = ".*-linux"
+
 KERNEL_PACKAGE_NAME ??= "kernel"
 KERNEL_DEPLOYSUBDIR ??= "${@ "" if (d.getVar("KERNEL_PACKAGE_NAME") == "kernel") else d.getVar("KERNEL_PACKAGE_NAME") }"
 
index 649fc04dd18e442d27634a89546d2210c1da36b9..95dc85ff2fccb93e12938f3f0c92cc5c1daccbd1 100644 (file)
@@ -26,7 +26,7 @@ DESCRIPTION_kernel-vmlinux = "Kernel vmlinux meta package"
 
 INHIBIT_DEFAULT_DEPS = "1"
 
-#COMPATIBLE_MACHINE = "your_machine"
+COMPATIBLE_HOST = ".*-linux"
 
 PR = "r1"