]> code.ossystems Code Review - openembedded-core.git/commitdiff
kbd: refresh patches
authorRoss Burton <ross.burton@intel.com>
Wed, 15 Nov 2017 16:47:41 +0000 (16:47 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 7 Mar 2018 14:33:55 +0000 (06:33 -0800)
The patch tool will apply patches by default with "fuzz", which is where if the
hunk context isn't present but what is there is close enough, it will force the
patch in.

Whilst this is useful when there's just whitespace changes, when applied to
source it is possible for a patch applied with fuzz to produce broken code which
still compiles (see #10450).  This is obviously bad.

We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For
that to be realistic the existing patches with fuzz need to be rebased and
reviewed.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/kbd/kbd/set-proper-path-of-resources.patch

index 27d6f42aaebe30a68601a449036c2568c121cc46..a9a3ab8abfbef05338d34f5583d452be38c4b81a 100644 (file)
@@ -13,10 +13,10 @@ run as expected.
 
 Signed-off-by: Kai Kang <kai.kang@windriver.com>
 
-diff --git a/tests/Makefile.am b/tests/Makefile.am
-index 1976333..b36aef3 100644
---- a/tests/Makefile.am
-+++ b/tests/Makefile.am
+Index: kbd-2.0.4/tests/Makefile.am
+===================================================================
+--- kbd-2.0.4.orig/tests/Makefile.am
++++ kbd-2.0.4/tests/Makefile.am
 @@ -1,7 +1,7 @@
  AM_CPPFLAGS = \
        -I$(srcdir)/../src/libkeymap \
@@ -25,11 +25,11 @@ index 1976333..b36aef3 100644
 +      -DDATADIR=\".\" -DBUILDDIR=\"$(builddir)\"
  
  AM_CFLAGS = $(CHECK_CFLAGS)
- LDADD  = $(top_builddir)/src/libkeymap/libkeymap.la $(CHECK_LIBS)
-diff --git a/tests/alt-is-meta.in b/tests/alt-is-meta.in
-index ddd5ed8..772fb51 100755
---- a/tests/alt-is-meta.in
-+++ b/tests/alt-is-meta.in
+ LDADD  = $(top_builddir)/src/libkeymap/libkeymap.la $(CHECK_LIBS) @INTLLIBS@
+Index: kbd-2.0.4/tests/alt-is-meta.in
+===================================================================
+--- kbd-2.0.4.orig/tests/alt-is-meta.in
++++ kbd-2.0.4/tests/alt-is-meta.in
 @@ -7,8 +7,8 @@ cd "$cwd"
  rc=0
  temp="$(mktemp "@BUILDDIR@/temp.XXXXXXXXX")"
@@ -41,10 +41,10 @@ index ddd5ed8..772fb51 100755
  
  if [ "$rc" != 0 ]; then
        printf 'failed\n'
-diff --git a/tests/dumpkeys-fulltable.in b/tests/dumpkeys-fulltable.in
-index 7c856e5..14d92c1 100755
---- a/tests/dumpkeys-fulltable.in
-+++ b/tests/dumpkeys-fulltable.in
+Index: kbd-2.0.4/tests/dumpkeys-fulltable.in
+===================================================================
+--- kbd-2.0.4.orig/tests/dumpkeys-fulltable.in
++++ kbd-2.0.4/tests/dumpkeys-fulltable.in
 @@ -5,7 +5,7 @@ cwd="$(readlink -ev "${0%/*}")"
  cd "$cwd"