]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa: Update 7.8.2 -> 7.11
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 12 Oct 2011 21:51:33 +0000 (22:51 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 12 Oct 2011 21:58:28 +0000 (22:58 +0100)
Pieces of this taken from patches from Martin Jansa <martin.jansa@gmail.com>
and likely from meta-oe.

It includes just enough changes to get the newer version to build.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.11.bb [new file with mode: 0644]
meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb [deleted file]
meta/recipes-graphics/mesa/mesa-dri_7.11.bb [moved from meta/recipes-graphics/mesa/mesa-dri_7.10.2.bb with 56% similarity]
meta/recipes-graphics/mesa/mesa-xlib_7.10.2.bb [deleted file]
meta/recipes-graphics/mesa/mesa-xlib_7.11.bb [new file with mode: 0644]

diff --git a/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.11.bb b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.11.bb
new file mode 100644 (file)
index 0000000..07247d5
--- /dev/null
@@ -0,0 +1,27 @@
+DESCRIPTION = "gl shader language specific build from mesa-dri"
+HOMEPAGE = "http://mesa3d.org"
+BUGTRACKER = "https://bugs.freedesktop.org"
+SECTION = "x11"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://glsl_parser.cpp;beginline=3;endline=33;md5=d078f1cddc2fc355719c090482254bd9"
+
+DEPENDS = "makedepend-native"
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2"
+SRC_URI[md5sum] = "ff03aca82d0560009a076a87c888cf13"
+SRC_URI[sha256sum] = "f8bf37a00882840a3e3d327576bc26a79ae7f4e18fe1f7d5f17a5b1c80dd7acf"
+
+S = "${WORKDIR}/Mesa-${PV}/src/glsl/"
+
+inherit native
+
+# use default config for native build
+do_configure_prepend() {
+       ln -s ${S}/../../configs/default ${S}/../../configs/current
+}
+
+do_install() {
+       install -d ${D}/${bindir}/glsl
+       install -m 755 ${S}/builtin_compiler ${D}/${bindir}/glsl/builtin_compiler
+       install -m 755 ${S}/glsl_compiler ${D}/${bindir}/glsl/glsl_compiler
+}
diff --git a/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb
deleted file mode 100644 (file)
index d6f2c33..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-DESCRIPTION = "gl shader language specific build from mesa-dri"
-HOMEPAGE = "http://mesa3d.org"
-BUGTRACKER = "https://bugs.freedesktop.org"
-SECTION = "x11"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://apps/compile.c;endline=26;md5=27c2833286ce9566b162bcbe21d5b267"
-PR = "r0"
-
-DEPENDS = "makedepend-native"
-
-SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2"
-SRC_URI[md5sum] = "6be2d343a0089bfd395ce02aaf8adb57"
-SRC_URI[sha256sum] = "505bf418dceba05837f4ea1b1972b9620c35f8cb94bc4d1e6d573c15f562576d"
-
-S = "${WORKDIR}/Mesa-7.8.2/src/glsl/"
-
-inherit native
-
-# use default config for native build
-do_configure_prepend() {
-       ln -s ${S}/../../configs/default ${S}/../../configs/current
-}
-
-do_install() {
-       install -d ${D}/${bindir}
-       install -m 755 ${S}/apps/compile ${D}/${bindir}/glsl-compile
-}
similarity index 56%
rename from meta/recipes-graphics/mesa/mesa-dri_7.10.2.bb
rename to meta/recipes-graphics/mesa/mesa-dri_7.11.bb
index 68f89a23101f99d276736229c829c2af15e494e2..6fc8d95e735137c3f8c5f1a40ab313baeb83b1a4 100644 (file)
@@ -7,23 +7,24 @@ LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat
             libxml2-native"
 
 DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS} makedepend-native python-native"
+DEPENDS += "mesa-dri-glsl-native"
 
-PR = "r2"
+PR = "r5"
 
 SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
            file://crossfix.patch \
            file://uclibc.patch \
           "
 
-SRC_URI[md5sum] = "f5de82852f1243f42cc004039e10b771"
-SRC_URI[sha256sum] = "8ced2678ce11cf30804694a92ea3ca6b82f158ae8995bdc626c7e85aac71c7c1"
+SRC_URI[md5sum] = "ff03aca82d0560009a076a87c888cf13"
+SRC_URI[sha256sum] = "f8bf37a00882840a3e3d327576bc26a79ae7f4e18fe1f7d5f17a5b1c80dd7acf"
 
 # most of our targets do not have DRI so will use mesa-xlib
 DEFAULT_PREFERENCE = "-1"
 
 LEAD_SONAME = "libGL.so.1"
 
-EXTRA_OECONF += "--with-driver=dri --disable-egl --disable-gallium"
+EXTRA_OECONF += "--with-driver=dri --disable-egl -with-dri-drivers=swrast,i915,i965 --without-gallium-drivers"
 
 python populate_packages_prepend() {
        import os.path
@@ -38,3 +39,10 @@ COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)'
 PACKAGES_DYNAMIC = "mesa-dri-driver-*"
 
 FILES_${PN}-dbg += "${libdir}/dri/.debug/*"
+
+do_configure_prepend() {
+       #check for python not python2, because python-native does not stage python2 binary/link
+       sed -i 's/AC_CHECK_PROGS(\[PYTHON2\], \[python2 python\])/AC_CHECK_PROGS(\[PYTHON2\], \[python python\])/g' ${S}/configure.ac
+       # We need builtin_compiler built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
+       sed -i "s#\./builtin_compiler#${STAGING_BINDIR_NATIVE}/glsl/builtin_compiler#g" ${S}/src/glsl/Makefile
+}
diff --git a/meta/recipes-graphics/mesa/mesa-xlib_7.10.2.bb b/meta/recipes-graphics/mesa/mesa-xlib_7.10.2.bb
deleted file mode 100644 (file)
index 511103d..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-include mesa-common.inc
-
-FILESPATH =. "${FILE_DIRNAME}/mesa-dri:"
-
-SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
-           file://uclibc.patch \
-           "
-
-SRC_URI[md5sum] = "f5de82852f1243f42cc004039e10b771"
-SRC_URI[sha256sum] = "8ced2678ce11cf30804694a92ea3ca6b82f158ae8995bdc626c7e85aac71c7c1"
-
-LIC_FILES_CHKSUM = "file://docs/license.html;md5=7a3373c039b6b925c427755a4f779c1d"
-
-PROTO_DEPS = "xf86driproto glproto"
-LIB_DEPS = "virtual/libx11 libxext libxxf86vm libxdamage libxfixes libxml2-native"
-
-DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS} makedepend-native"
-
-PE = "1"
-PR = "r1"
-
-EXTRA_OECONF += "--with-driver=xlib"
diff --git a/meta/recipes-graphics/mesa/mesa-xlib_7.11.bb b/meta/recipes-graphics/mesa/mesa-xlib_7.11.bb
new file mode 100644 (file)
index 0000000..ea4acc6
--- /dev/null
@@ -0,0 +1,30 @@
+include mesa-common.inc
+
+FILESPATH =. "${FILE_DIRNAME}/mesa-dri:"
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
+           file://uclibc.patch \
+           "
+
+SRC_URI[md5sum] = "ff03aca82d0560009a076a87c888cf13"
+SRC_URI[sha256sum] = "f8bf37a00882840a3e3d327576bc26a79ae7f4e18fe1f7d5f17a5b1c80dd7acf"
+
+LIC_FILES_CHKSUM = "file://docs/license.html;md5=7a3373c039b6b925c427755a4f779c1d"
+
+PROTO_DEPS = "xf86driproto glproto"
+LIB_DEPS = "virtual/libx11 libxext libxxf86vm libxdamage libxfixes libxml2-native"
+
+DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS} makedepend-native"
+
+PE = "1"
+PR = "r1"
+
+EXTRA_OECONF += "--with-driver=xlib --without-gallium-drivers"
+
+do_configure_prepend() {
+       #check for python not python2, because python-native does not stage python2 binary/link
+       sed -i 's/AC_CHECK_PROGS(\[PYTHON2\], \[python2 python\])/AC_CHECK_PROGS(\[PYTHON2\], \[python python\])/g' ${S}/configure.ac
+       # We need builtin_compiler built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
+       sed -i "s#\./builtin_compiler#${STAGING_BINDIR_NATIVE}/glsl/builtin_compiler#g" ${S}/src/glsl/Makefile
+}
+