]> code.ossystems Code Review - openembedded-core.git/commitdiff
gst-plugins-ugly: add PACKAGECONFIG for x264, cdio, dvdread
authorMartin Jansa <Martin.Jansa@gmail.com>
Thu, 11 Jul 2013 20:27:43 +0000 (22:27 +0200)
committerSaul Wold <sgw@linux.intel.com>
Tue, 23 Jul 2013 14:22:38 +0000 (07:22 -0700)
* they are autodetected from sysroot

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-multimedia/gstreamer/gst-plugins-ugly_0.10.19.bb

index 9fd71fcd64efde11747f6fcf9aec65348d5a0c40..2fdf03f348a57289ce06b79453577d1eaa897a97 100644 (file)
@@ -15,6 +15,11 @@ inherit gettext
 EXTRA_OECONF += "--with-plugins=a52dec,lame,id3tag,mad,mpeg2dec,mpegstream,mpegaudioparse,asfdemux,realmedia \
                  --disable-orc"
 
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[x264] = "--enable-x264,--disable-x264,x264"
+PACKAGECONFIG[cdio] = "--enable-cdio,--disable-cdio,libcdio"
+PACKAGECONFIG[dvdread] = "--enable-dvdread,--disable-dvdread,libdvdread"
+
 do_configure_prepend() {
        # This m4 file contains nastiness which conflicts with libtool 2.2.2
        rm ${S}/m4/lib-link.m4 || true