]> code.ossystems Code Review - openembedded-core.git/commitdiff
resolveconf: Fix file owners
authorMark Hatle <mark.hatle@windriver.com>
Mon, 20 Jun 2011 18:00:03 +0000 (13:00 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 23 Jun 2011 20:01:48 +0000 (21:01 +0100)
The file ownership of various configuration files needs to be set to root:root
otherwise it inherits the user id of the build.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-connectivity/resolvconf/resolvconf_1.48.bb

index cb8aaaf5368ca22c0f3c1b5fbb6d6cd3cafc2458..507a233709b08ae2cd996acc42fb2ff3bf1dcd96 100644 (file)
@@ -11,7 +11,7 @@ AUTHOR = "Thomas Hood"
 HOMEPAGE = "http://packages.debian.org/resolvconf"
 DEPENDS = "bash"
 RDEPENDS_${PN} = "bash"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/r/resolvconf/resolvconf_${PV}.tar.gz"
 
@@ -27,6 +27,7 @@ do_install () {
        install -d ${D}${sysconfdir} ${D}${sbindir} ${D}${base_sbindir} ${D}${localstatedir}/volatile/run/resolvconf/interface
        install -d ${D}${mandir}/man8 ${D}${docdir}/${P}
        cp -pPR etc/* ${D}${sysconfdir}/
+       chown -R root:root ${D}${sysconfdir}/
        install -m 0755 bin/resolvconf ${D}${base_sbindir}/
        install -m 0644 README ${D}${docdir}/${P}/
        install -m 0644 man/resolvconf.8 ${D}${mandir}/man8/