]> code.ossystems Code Review - openembedded-core.git/commitdiff
package_ip.bbclass: add xz threading
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>
Wed, 26 Dec 2018 23:59:06 +0000 (17:59 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 27 Dec 2018 22:50:00 +0000 (22:50 +0000)
Before, threading was enabled via a patch to opkg-build. Now that
opkg-build provides a hook for extra arguments, use that.

Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/package_ipk.bbclass

index 5eb910ca3184178ffc83d8ad21efa854afdf8aed..508b7dcaff4f08a4482fe33e2470fd8c44c957a9 100644 (file)
@@ -8,7 +8,7 @@ IPKGCONF_SDK =  "${WORKDIR}/opkg-sdk.conf"
 PKGWRITEDIRIPK = "${WORKDIR}/deploy-ipks"
 
 # Program to be used to build opkg packages
-OPKGBUILDCMD ??= "opkg-build -Z xz"
+OPKGBUILDCMD ??= 'opkg-build -Z xz -a "--threads 0"'
 
 OPKG_ARGS += "--force_postinstall --prefer-arch-to-version"
 OPKG_ARGS += "${@['', '--no-install-recommends'][d.getVar("NO_RECOMMENDATIONS") == "1"]}"