]> code.ossystems Code Review - openembedded-core.git/commitdiff
alsa-state: ignore 'No soundcards found' error in pkg_postinst
authorYi Zhao <yi.zhao@windriver.com>
Fri, 17 Apr 2020 10:15:27 +0000 (18:15 +0800)
committerSteve Sakoman <steve@sakoman.com>
Thu, 30 Apr 2020 21:59:59 +0000 (11:59 -1000)
If there is no soundcards on the target (e.g. qemu), the pkp_postinst
function will report an error:
  alsactl: load_state:1735: No soundcards found...
  pkg_run_script: package "alsa-state" postinst script returned status 19.
  opkg_configure: alsa-state.postinst returned 19.

Pass '-g' option to alsactl to ignore this error.

Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-bsp/alsa-state/alsa-state.bb

index 06705569998290e3dfe47b453488c7c58b5ec74c..cec2272c80c6fa4b5e7659c2aa7105fcec3eb1eb 100644 (file)
@@ -62,7 +62,7 @@ pkg_postinst_${PN}() {
        then
                if test -x ${sbindir}/alsactl
                then
-                       ${sbindir}/alsactl -f ${localstatedir}/lib/alsa/asound.state restore
+                       ${sbindir}/alsactl -g -f ${localstatedir}/lib/alsa/asound.state restore
                fi
        fi
 }