]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3: add missing dependency on PN-misc to PN-modules
authorRoss Burton <ross.burton@intel.com>
Wed, 13 Jan 2016 12:55:46 +0000 (12:55 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 17 Jan 2016 11:32:20 +0000 (11:32 +0000)
Installing python3-modules should install *all* of the Python standard library,
not just most of it.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3_3.5.0.bb

index d5e26ff764177f96aa4d64c70b24ac4de070e7d9..6184c79fb1e46e90df5d73829a715a4e48340652 100644 (file)
@@ -215,6 +215,7 @@ FILES_libpython3-staticdev += "${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_
 # catch all the rest (unsorted)
 PACKAGES += "${PN}-misc"
 RDEPENDS_${PN}-misc += "${PN}-core"
+RDEPENDS_${PN}-modules += "${PN}-misc"
 FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}"
 
 # catch manpage