]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssh: Fix non-deterministic build behaviour
authorDan McGregor <dan.mcgregor@usask.ca>
Wed, 4 Feb 2015 16:09:13 +0000 (10:09 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 7 Feb 2015 18:52:44 +0000 (18:52 +0000)
If maillock.h is found, a dependency on liblockfile will be created.
liblockfile is in meta-oe, so we don't want that in an oe-core recipe.

Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-connectivity/openssh/openssh_6.7p1.bb

index dcbc181aa9a907a6e4205d9d460849a80b74ce4f..a2726291fe38fa8a39d41395be431cc63e6a3fc7 100644 (file)
@@ -62,6 +62,9 @@ CACHED_CONFIGUREVARS += "ac_cv_header_bsd_libutil_h=no ac_cv_header_libutil_h=no
 # passwd path is hardcoded in sshd
 CACHED_CONFIGUREVARS += "ac_cv_path_PATH_PASSWD_PROG=${bindir}/passwd"
 
+# We don't want to depend on libblockfile
+CACHED_CONFIGUREVARS += "ac_cv_header_maillock_h=no"
+
 # This is a workaround for uclibc because including stdio.h
 # pulls in pthreads.h and causes conflicts in function prototypes.
 # This results in compilation failure, so unless this is fixed,