]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta: remove some EXCLUDE_FROM_WORLD assignments
authorRoss Burton <ross.burton@intel.com>
Mon, 12 Mar 2018 16:38:57 +0000 (16:38 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 12 Mar 2018 22:46:34 +0000 (15:46 -0700)
Now that we have recipe-specific-sysroots we don't need to exclude recipes from
world builds because they conflict with other recipes, as they'll all be built
with their own sysroots.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/bluez5/bluez5.inc
meta/recipes-graphics/mesa/mesa.inc
meta/recipes-graphics/xorg-lib/libx11.inc
meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb

index a73d9568e588230f7fdd8058b58bea0d158d3fa7..ae2a833c0cb1de0f95f83bd7df17cec35989f271 100644 (file)
@@ -136,8 +136,6 @@ SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'bluet
 INITSCRIPT_PACKAGES = "${PN}"
 INITSCRIPT_NAME_${PN} = "bluetooth"
 
-EXCLUDE_FROM_WORLD = "1"
-
 do_compile_ptest() {
        oe_runmake buildtests
 }
index 88ba0050d5e97c6144c33c7bf112c4addd99e4c6..23ae651f7d129d47d00f0191baf14f0080014d08 100644 (file)
@@ -99,9 +99,6 @@ FULL_OPTIMIZATION_append = " -fno-omit-frame-pointer"
 
 CFLAGS_append_armv5 = " -DMISSING_64BIT_ATOMICS"
 
-# Multiple virtual/gl providers being built breaks staging
-EXCLUDE_FROM_WORLD = "1"
-
 # Remove the mesa dependency on mesa-dev, as mesa is empty
 RDEPENDS_${PN}-dev = ""
 
index b04eafbdf2f7c9513193c3d9fb3ace4b03a7ec6b..4af40ab8a1c26afc39973dc40f1c771d8f407a4d 100644 (file)
@@ -35,7 +35,3 @@ PACKAGES =+ "${PN}-xcb"
 FILES_${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB ${datadir}/X11/Xcms.txt"
 FILES_${PN}-xcb += "${libdir}/libX11-xcb.so.*"
 FILES_${PN}-locale += "${datadir}/X11/locale ${libdir}/X11/locale"
-
-# Multiple libx11 derivatives from from this file and are selected by virtual/libx11
-# A world build should only build the correct version, not all of them.
-EXCLUDE_FROM_WORLD = "1"
index 889878ddc003ac7d4148f50715aeb50c9c32c5d6..d63701e5a05ae3073ecf952748be68476471ef4c 100644 (file)
@@ -24,9 +24,3 @@ do_configure() {
        oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \
                   -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} scripts
 }
-
-
-# There is no reason to build this on its own.
-#
-EXCLUDE_FROM_WORLD = "1"
-