]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/3.14: fix qemumips build error
authorBruce Ashfield <bruce.ashfield@windriver.com>
Fri, 8 May 2015 03:36:13 +0000 (23:36 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 9 May 2015 21:25:47 +0000 (22:25 +0100)
Updating the SRCREVs to import the following fix:

    mips: define cpu_has_saa in common features include

    To avoid build failures such as the following on non-cavium
    platforms:

     | arch/mips/include/asm/atomic.h: In function 'atomic_add':
     | arch/mips/include/asm/atomic.h:52:6: error: 'cpu_has_saa'
     | undeclared (first use in this function)
     |   if (cpu_has_saa) {
     |       ^

    We define a disabled cpu_has_saa unless the machine specific feature
    overrides define a value.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
meta/recipes-kernel/linux/linux-yocto_3.14.bb

index 23e1688daeda2bccda1b0978706bdeea29b5155d..86b31738b6094dec70276a0c06b25756d6f3ee2a 100644 (file)
@@ -3,8 +3,8 @@ KBRANCH_qemuppc ?= "standard/preempt-rt/qemuppc"
 
 require recipes-kernel/linux/linux-yocto.inc
 
-SRCREV_machine ?= "91dc6afcecd47c08e7e13e674d8d7e9dcede5aca"
-SRCREV_machine_qemuppc ?= "2655b44cfe839f6f9ba15b061e1b4d386d5821f6"
+SRCREV_machine ?= "0c641a6c0e38137364535b99e43657a0cbc07cd4"
+SRCREV_machine_qemuppc ?= "cfc4e296efcaa84358c9ab1cdeee6ce7c378436f"
 SRCREV_meta ?= "46df2668fa657162d11f96a6f1af138c562a03aa"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
index 1d999650611c7bcb83ec627a37b96e383fd08671..d0b71c4859b195d60ad9510a418f4f17d1a2e974 100644 (file)
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "3.14.36"
 KMETA = "meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine ?= "2a2be8720802fae73fbdf1da37f61d7843332ba3"
+SRCREV_machine ?= "b991a586470900e3de824f5ea75653aa2150594d"
 SRCREV_meta ?= "46df2668fa657162d11f96a6f1af138c562a03aa"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
index fa433b61c821832b82ad3b34ebf70f75c4c04add..d4ea55a2398e889b5f69250d8c52378b53eb5b11 100644 (file)
@@ -11,14 +11,14 @@ KBRANCH_qemux86  ?= "standard/common-pc/base"
 KBRANCH_qemux86-64 ?= "standard/common-pc-64/base"
 KBRANCH_qemumips64 ?= "standard/mti-malta64"
 
-SRCREV_machine_qemuarm ?= "90f1033d72d422b4e4a8125f68cd1623d6788870"
-SRCREV_machine_qemuarm64 ?= "2a2be8720802fae73fbdf1da37f61d7843332ba3"
-SRCREV_machine_qemumips ?= "bc927927f774c9d12f6c4689dbfba9f5578d0b62"
-SRCREV_machine_qemuppc ?= "e4dfdbf1a059e0edb1be677973f8e2c73e012c8a"
-SRCREV_machine_qemux86 ?= "594bfbce3133d75d9aa569883bdeaed15eeadc8f"
-SRCREV_machine_qemux86-64 ?= "2a2be8720802fae73fbdf1da37f61d7843332ba3"
-SRCREV_machine_qemumips64 ?= "ea8b5406c6ec027d0475146ac84f24eb34196b78"
-SRCREV_machine ?= "2a2be8720802fae73fbdf1da37f61d7843332ba3"
+SRCREV_machine_qemuarm ?= "e4f91293908648d495b4f9735768633569e39b9f"
+SRCREV_machine_qemuarm64 ?= "b991a586470900e3de824f5ea75653aa2150594d"
+SRCREV_machine_qemumips ?= "6623389731309b0ac591736d5b438de833f195c7"
+SRCREV_machine_qemuppc ?= "3217fbcd002914fba4914d2e61dabb378081fd25"
+SRCREV_machine_qemux86 ?= "8794bd6a473199b2baa7a405d44cdbfa5351b60b"
+SRCREV_machine_qemux86-64 ?= "b991a586470900e3de824f5ea75653aa2150594d"
+SRCREV_machine_qemumips64 ?= "6649ef219b3bf6da1678547b9da376367520e80a"
+SRCREV_machine ?= "b991a586470900e3de824f5ea75653aa2150594d"
 SRCREV_meta ?= "46df2668fa657162d11f96a6f1af138c562a03aa"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"