]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: Cache/define tool paths for target
authorKhem Raj <raj.khem@gmail.com>
Sat, 15 Aug 2015 22:04:31 +0000 (15:04 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 30 Aug 2015 11:34:16 +0000 (12:34 +0100)
Recently, systemd has added a patch

f00929ad622c978f8ad83590a15a765b4beecac9

where it now pokes at the system to find
out the path of mount/umount tools, this caused the builds to fail
because it ended up with identifying these programs from native sysroot
but they were actually meant for target, this lead to boot failures due
to none of mount worked because the paths are encoded into systemd
binaries during build time.

Correct few others while here, these are not yet detected wrongly in my
build, because those binaries are not found in my native sysroot but if
some one staged the native providers of these packages they will fail too.

(From OE-Core rev: 9d87fbc87276673d958a65d476d06fec96add8e7)

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd_219.bb

index 98bf66f4501a6429f414dd077d0056e3bfb49582..4d32fd5b620b00e168cca51ca13a0b6728ee7429 100644 (file)
@@ -104,7 +104,17 @@ rootprefix ?= "${base_prefix}"
 rootlibdir ?= "${base_libdir}"
 rootlibexecdir = "${rootprefix}/lib"
 
-# The gtk+ tools should get built as a separate recipe e.g. systemd-tools
+CACHED_CONFIGUREVARS_class-target = "\
+                         ac_cv_path_MOUNT_PATH=${base_bindir}/mount \
+                         ac_cv_path_UMOUNT_PATH=${base_bindir}/umount \
+                         ac_cv_path_KMOD=${base_bindir}/kmod \
+                         ac_cv_path_KILL=${base_bindir}/kill \
+                         ac_cv_path_SULOGIN=${base_sbindir}/sulogin \
+                         ac_cv_path_KEXEC=${sbindir}/kexec \
+                         ac_cv_path_QUOTACHECK=${sbindir}/quotacheck \
+                         ac_cv_path_QUOTAON=${sbindir}/quotaon \
+                        "
+
 EXTRA_OECONF = " --with-rootprefix=${rootprefix} \
                  --with-rootlibdir=${rootlibdir} \
                  --with-roothomedir=${ROOT_HOME} \