]> code.ossystems Code Review - openembedded-core.git/commitdiff
u-boot-mkimage: fix recompile error
authorRobert Yang <liezhi.yang@windriver.com>
Thu, 7 Aug 2014 03:05:22 +0000 (20:05 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 11 Aug 2014 09:46:59 +0000 (10:46 +0100)
Fixed:
make: *** No rule to make target `/path/to/sysroot/4.9.0/include/stddef.h', needed by `crc32.o'.  Stop.
make: *** Waiting for unfinished jobs....
ERROR: oe_runmake failed

This happens when upgrade gcc from 4.9.0 to 4.9.1, and the .depend isn't
regenerated when recompile, the content of it are:

[snip]
crc32.o: /path/to/sysroot/4.9.0/include/stddef.h
[snip]

And Makefile includes the .depend file if it exists, so there would be
errors when /path/to/sysroot/4.9.0/include/stddef.h doesn't exist.

Remove .*.d (a few .d files, its Makefile uses this wildcard) will fix
the problem.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb

index 2ca6050bf9fab671aba8e9f4c8e7f929107f5ccf..93c8102e73422c44bcedcffdca6d437fd462effe 100644 (file)
@@ -17,6 +17,9 @@ S = "${WORKDIR}/git"
 EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
 
 do_compile () {
+  # Make sure the recompile is OK
+  rm -f ${B}/tools/.depend
+
   oe_runmake tools
 }