]> code.ossystems Code Review - openembedded-core.git/commitdiff
e2fsprogs_1.43.8.bb: improve reproducibility
authorJuro Bystricky <juro.bystricky@intel.com>
Sat, 3 Mar 2018 01:02:00 +0000 (17:02 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 6 Mar 2018 14:36:35 +0000 (06:36 -0800)
Various builds of e2fsprogs 1.43.7 package locales which may or may
not have POT-Creation-Date removed. There is no obvious pattern, it
affects different locales each time, the build being non-deterministic.

The root cause was tracked to non-deterministic time stamps (as GIT does
not preserve file mktime), so some "make" rules sometimes fired, sometimes
did not.

The remedy is to explicitly "touch" files that cause non-deterministic build.

[YOCTO #12516]

Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/e2fsprogs/e2fsprogs_1.43.8.bb

index ceaf1715854af9b996fba42f55b807fbc0f3358e..4fa976d51f37afb464016b3e3f1ea473ce402155 100644 (file)
@@ -25,6 +25,9 @@ EXTRA_OECONF_darwin = "--libdir=${base_libdir} --sbindir=${base_sbindir} --enabl
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[fuse] = '--enable-fuse2fs,--disable-fuse2fs,fuse'
 
+do_compile_prepend (){
+       find ${S}/po -type f -name "*.po" -exec touch {} +
+}
 
 do_install () {
        oe_runmake 'DESTDIR=${D}' install