]> code.ossystems Code Review - openembedded-core.git/commitdiff
initscripts: dropped suport for mtdram style ramdisk
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 13 Jun 2008 14:20:09 +0000 (14:20 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 13 Jun 2008 14:20:09 +0000 (14:20 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4641 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/initscripts/initscripts-1.0/ramdisk [deleted file]
meta/packages/initscripts/initscripts_1.0.bb

diff --git a/meta/packages/initscripts/initscripts-1.0/ramdisk b/meta/packages/initscripts/initscripts-1.0/ramdisk
deleted file mode 100755 (executable)
index 4dfe53c..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/bin/sh
-
-. /etc/default/rcS
-
-FSTYPE=ext2
-
-if test ! -e /proc/mtd
-then
-       test "$VERBOSE" != "no" && echo >&2 "/proc not mounted, or mtd support not enabled in kernel."
-       exit
-fi
-
-RAM_MTD_NO=`cat /proc/mtd | grep mtdram | tail -n 1 | cut -d: -f1 | cut -dd -f2`
-if test -z "$RAM_MTD_NO"; then exit 0; fi
-
-if test -e /dev/mtdblock/0
-then
-       RAM_MTD=/dev/mtd/$RAM_MTD_NO
-       RAM_MTDBLK=/dev/mtdblock/$RAM_MTD_NO
-else
-       RAM_MTD=/dev/mtd$RAM_MTD_NO
-       RAM_MTDBLK=/dev/mtdblock$RAM_MTD_NO
-fi
-
-if grep -q $RAM_MTDBLK /etc/mtab; then echo "Device $RAM_MTDBLK already mounted"; exit 0; fi
-if test ! -e $RAM_MTD; then echo >&2 "Mtdram device $RAM_MTD does not exist!"; exit 1; fi
-
-RAM_MNTPT=/mnt/ram
-RAM_MTD_SIZE_HEX=`cat /proc/mtd | grep mtdram | tail -n 1 | cut -d" " -f 2`
-RAM_MTD_SIZE=`dc 0x$RAM_MTD_SIZE_HEX 1024 / p`
-test -e /etc/ramdisk.conf && OLD_MTD_SIZE=`cat /etc/ramdisk.conf`
-echo $RAM_MTD_SIZE > /etc/ramdisk.conf
-
-if test ! -d "$RAM_MNTPT"; then echo >&2 "Mountpoint $RAM_MNTPT does not exist!"; exit 0; fi
-
-if (test ! -e /etc/.configured) || test "$OLD_MTD_SIZE" != "$RAM_MTD_SIZE"; then
-  test "$VERBOSE" != "no" && echo -n "Wiping ramdisk: "
-  dd if=/dev/zero bs=1024 count=$RAM_MTD_SIZE of=$RAM_MTD 2>/dev/null >&2 || exit 1
-  test "$VERBOSE" != "no" && echo "$RAM_MTD";
-  test "$VERBOSE" != "no" && echo -n "Creating filesystem on ramdisk: "
-  mkfs.$FSTYPE $RAM_MTDBLK 2>/dev/null >&2 || exit 1
-  test "$VERBOSE" != "no" && echo "$RAM_MTDBLK";
-fi
-
-test "$VERBOSE" != "no" && echo -n "Mounting ramdisk: "
-mount -t $FSTYPE $RAM_MTDBLK $RAM_MNTPT 2>/dev/null >&2 || exit 1
-test "$VERBOSE" != "no" && echo "$RAM_MTDBLK";
-
-exit 0
index ac01a428191385eb7dafdb32c17c1b938413e7e3..17abd0a0ba392aa7554a8bf494fd520cd56cd1b6 100644 (file)
@@ -4,11 +4,10 @@ PRIORITY = "required"
 DEPENDS = "makedevs"
 RDEPENDS = "makedevs"
 LICENSE = "GPL"
-PR = "r107"
+PR = "r108"
 
 SRC_URI = "file://functions \
            file://halt \
-           file://ramdisk \
            file://umountfs \
            file://devpts.sh \
            file://devpts \
@@ -60,7 +59,6 @@ do_install () {
        install -m 0755    ${WORKDIR}/hostname.sh       ${D}${sysconfdir}/init.d
        install -m 0755    ${WORKDIR}/mountall.sh       ${D}${sysconfdir}/init.d
        install -m 0755    ${WORKDIR}/mountnfs.sh       ${D}${sysconfdir}/init.d
-       install -m 0755    ${WORKDIR}/ramdisk           ${D}${sysconfdir}/init.d
        install -m 0755    ${WORKDIR}/reboot            ${D}${sysconfdir}/init.d
        install -m 0755    ${WORKDIR}/rmnologin ${D}${sysconfdir}/init.d
        install -m 0755    ${WORKDIR}/sendsigs          ${D}${sysconfdir}/init.d
@@ -93,7 +91,6 @@ do_install () {
        ln -sf          ../init.d/umountnfs.sh  ${D}${sysconfdir}/rc6.d/S31umountnfs.sh
        ln -sf          ../init.d/umountfs      ${D}${sysconfdir}/rc6.d/S40umountfs
        # udev will run at S55 if installed
-       ln -sf          ../init.d/ramdisk       ${D}${sysconfdir}/rcS.d/S30ramdisk
        ln -sf          ../init.d/reboot        ${D}${sysconfdir}/rc6.d/S90reboot
        ln -sf          ../init.d/sendsigs      ${D}${sysconfdir}/rc0.d/S20sendsigs
 #      ln -sf          ../init.d/urandom       ${D}${sysconfdir}/rc0.d/S30urandom