]> code.ossystems Code Review - openembedded-core.git/commitdiff
patch: fix CVE-2019-20633
authorScott Murray <scott.murray@konsulko.com>
Wed, 30 Dec 2020 22:44:18 +0000 (17:44 -0500)
committerAnuj Mittal <anuj.mittal@intel.com>
Thu, 7 Jan 2021 07:01:08 +0000 (15:01 +0800)
* CVE detail: https://nvd.nist.gov/vuln/detail/CVE-2019-20633

* upstream tracking: https://savannah.gnu.org/bugs/index.php?56683

* Fixes potential for double free after incomplete fix for CVE-2018-6952
  - src/pch.c (another_hunk): Avoid invalid memory access in context format
    diffs.

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit be71dd2cc16a4c0d244a76a748f08ca0d9bfeba0)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-devtools/patch/patch/CVE-2019-20633.patch [new file with mode: 0644]
meta/recipes-devtools/patch/patch_2.7.6.bb

diff --git a/meta/recipes-devtools/patch/patch/CVE-2019-20633.patch b/meta/recipes-devtools/patch/patch/CVE-2019-20633.patch
new file mode 100644 (file)
index 0000000..03988a1
--- /dev/null
@@ -0,0 +1,31 @@
+From 15b158db3ae11cb835f2eb8d2eb48e09d1a4af48 Mon Sep 17 00:00:00 2001
+From: Andreas Gruenbacher <agruen@gnu.org>
+Date: Mon, 15 Jul 2019 19:10:02 +0200
+Subject: Avoid invalid memory access in context format diffs
+
+* src/pch.c (another_hunk): Avoid invalid memory access in context format
+diffs.
+
+CVE: CVE-2019-20633
+Upstream-Status: Backport[https://git.savannah.gnu.org/cgit/patch.git/patch/?id=15b158db3ae11cb835f2eb8d2eb48e09d1a4af48]
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+---
+ src/pch.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/pch.c b/src/pch.c
+index a500ad9..cb54e03 100644
+--- a/src/pch.c
++++ b/src/pch.c
+@@ -1328,6 +1328,7 @@ another_hunk (enum diff difftype, bool rev)
+                 ptrn_prefix_context = context;
+               ptrn_suffix_context = context;
+               if (repl_beginning
++                  || p_end <= 0
+                   || (p_end
+                       != p_ptrn_lines + 1 + (p_Char[p_end - 1] == '\n')))
+                 {
+-- 
+cgit v1.2.1
+
index b5897b357ae79bd1942deb127a2468bb428a4454..1997af0c25536107177a20b6f3671fbc51ccd017 100644 (file)
@@ -10,6 +10,7 @@ SRC_URI += "file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
             file://0001-Invoke-ed-directly-instead-of-using-the-shell.patch \
             file://0001-Don-t-leak-temporary-file-on-failed-ed-style-patch.patch \
             file://0001-Don-t-leak-temporary-file-on-failed-multi-file-ed.patch \
+            file://CVE-2019-20633.patch \
 "
 
 SRC_URI[md5sum] = "4c68cee989d83c87b00a3860bcd05600"