]> code.ossystems Code Review - openembedded-core.git/commitdiff
packagegroup-core-gtk-directfb: remove superfluous -base package
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Thu, 30 Aug 2012 13:48:06 +0000 (14:48 +0100)
committerSaul Wold <sgw@linux.intel.com>
Tue, 4 Sep 2012 05:52:51 +0000 (22:52 -0700)
There's only one package, just make it the main one; also update
core-image-gtk-directfb to match and tidy it up a bit.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-graphics/images/core-image-gtk-directfb.bb
meta/recipes-graphics/packagegroups/packagegroup-core-gtk-directfb.bb

index 868b3097f25117a612adf375938206bae87ff7ad..05f03cdcefac98623c44058d59be8b50375f1c9b 100644 (file)
@@ -6,18 +6,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
 
-DEPENDS += "packagegroup-core-gtk-directfb"
-
-RDEPENDS_${PN} += " \
-       packagegroup-core-gtk-directfb-base \
-       "
-
 inherit core-image
 
 IMAGE_INSTALL += "\
        ${CORE_IMAGE_BASE_INSTALL} \
        packagegroup-core-basic \
-       packagegroup-core-gtk-directfb-base \
+       packagegroup-core-gtk-directfb \
 "
 
 python __anonymous () {
index 0c47b6fbcd669ecad064fa1b42203534d48f3c93..2f35b34ca55e5d6962177aa6c36dce76862049aa 100644 (file)
@@ -7,11 +7,9 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
 
 inherit packagegroup
 
-PACKAGES = "${PN}-base"
-
 TOUCH = ' ${@base_contains("MACHINE_FEATURES", "touchscreen", "tslib tslib-calibrate tslib-tests", "",d)}'
 
-RDEPENDS_${PN}-base = " \
+RDEPENDS_${PN} = " \
                directfb \
                directfb-examples \
                pango \