]> code.ossystems Code Review - openembedded-core.git/commitdiff
trace-cmd: fix cross-compilation
authorDarren Hart <dvhart@linux.intel.com>
Wed, 29 Dec 2010 01:17:25 +0000 (17:17 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Jan 2011 10:06:28 +0000 (10:06 +0000)
The trace-cmd Makefile forces certain variables, such as CC and AR.
It was using the host gcc and loader, fix it to use the poky-built
cross-compiler and linker.

inherit pkgconfig to ensure we don't use the host pkg-config.

Remove unecessary variables from the oemake commands, such as ARCH
and LD which aren't used by the Makefile.

Signed-off-by: Darren Hart <dvhart@linux.intel.com>
CC: Tom Zanussi <tom.zanussi@intel.com>
meta/recipes-kernel/trace-cmd/trace-cmd_git.bb

index e375afcade6807c36db397d9650519cc497bd65e..a7eca5f9b81cec942af2a5ce91d57d185bf2d770 100644 (file)
@@ -2,18 +2,16 @@ DESCRIPTION = "User interface to Ftrace"
 LICENSE = "GPL"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 
-PR = r1
+PR = r2
 PV = "1.0.4+git${SRCPV}"
 
+inherit pkgconfig
+
 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git;protocol=git"
 S = "${WORKDIR}/git"
 
-
-do_compile() { 
-       oe_runmake ARCH="${ARCH}" CC="${CC}" LD="${LD}" prefix=${prefix}
-}
+EXTRA_OEMAKE = "'CC=${CC}' 'AR=${AR}' 'prefix=${prefix}'"
 
 do_install() {
-       oe_runmake ARCH="${ARCH}" CC="${CC}" LD="${LD}" \
-                   prefix=${prefix} DESTDIR=${D} install
+       oe_runmake CC="${CC}" AR="${AR}" prefix="${prefix}" DESTDIR="${D}" install
 }