]> code.ossystems Code Review - openembedded-core.git/commitdiff
BBHandler: simplify supports()
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sun, 14 Nov 2010 12:08:03 +0000 (13:08 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 4 Jan 2011 14:46:39 +0000 (14:46 +0000)
(Bitbake rev: 858d704d713d15bf97053eb1374758c74b0d8874)

Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
bitbake/lib/bb/parse/parse_py/BBHandler.py

index 31f44f7df3e464ea79723c91f34a021ebde18ae3..ac981b83469dff6e8f884dc49eed224c78341b81 100644 (file)
@@ -65,7 +65,8 @@ IN_PYTHON_EOF = -9999999999999
 
 
 def supports(fn, d):
-    return fn[-3:] == ".bb" or fn[-8:] == ".bbclass" or fn[-4:] == ".inc"
+    """Return True if fn has a supported extension"""
+    return os.path.splitext(fn)[-1] in [".bb", ".bbclass", ".inc"]
 
 def inherit(files, d):
     __inherit_cache = data.getVar('__inherit_cache', d) or []