]> code.ossystems Code Review - openembedded-core.git/commitdiff
db: do not install db_verify if 'verify' is not enabled
authorChen Qi <Qi.Chen@windriver.com>
Fri, 5 Jun 2020 02:09:45 +0000 (10:09 +0800)
committerSteve Sakoman <steve@sakoman.com>
Tue, 16 Jun 2020 20:14:02 +0000 (10:14 -1000)
On target, when running `db_verify /var/lib/rpm/Packages', we get
the following error.

  db_verify: BDB0571 library build did not include support for database verification

This is because db_verify is installed but 'verify' PACKAGECONFIG is
not enabled. So fix it by not installing do_verify in such case.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit b5ffdb296f211403f987b5d5a724a94ee91dc80c)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-support/db/db_5.3.28.bb

index 3a0923ae360d90a7ca4e36e37e89cde46e322440..318efcb61de51b9f6bda56c27c7d032fba20603c 100644 (file)
@@ -109,6 +109,9 @@ do_install_append() {
        fi
 
        chown -R root:root ${D}
+       if ${@bb.utils.contains('PACKAGECONFIG', 'verify', 'false', 'true', d)}; then
+               rm -f ${D}${bindir}/db_verify
+       fi
 }
 
 INSANE_SKIP_${PN} = "dev-so"