]> code.ossystems Code Review - openembedded-core.git/commitdiff
add psplash
authorRichard Purdie <richard@openedhand.com>
Thu, 28 Sep 2006 14:20:06 +0000 (14:20 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 28 Sep 2006 14:20:06 +0000 (14:20 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@770 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/psplash/files/psplash-init [new file with mode: 0755]
meta/packages/psplash/psplash_0.0.bb [new file with mode: 0644]

diff --git a/meta/packages/psplash/files/psplash-init b/meta/packages/psplash/files/psplash-init
new file mode 100755 (executable)
index 0000000..b736cc6
--- /dev/null
@@ -0,0 +1,7 @@
+#!/bin/sh 
+
+export TMPDIR=/mnt/.psplash
+mount tmpfs -t tmpfs $TMPDIR -o,size=40k
+
+/usr/bin/psplash &
+
diff --git a/meta/packages/psplash/psplash_0.0.bb b/meta/packages/psplash/psplash_0.0.bb
new file mode 100644 (file)
index 0000000..a64b4c2
--- /dev/null
@@ -0,0 +1,22 @@
+DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
+SECTION = "base"
+MAINTAINER = "Matthew Allum <mallum@openedhand.com>"
+LICENSE = "GPL"
+
+SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
+           file://psplash-init"
+
+S = "${WORKDIR}/psplash"
+
+inherit autotools pkgconfig update-rc.d
+
+FILES_${PN} += "/mnt/.psplash"
+
+do_install_prepend() {
+       install -d ${D}/mnt/.psplash/
+       install -d ${D}${sysconfdir}/init.d/
+       install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash
+}
+
+INITSCRIPT_NAME = "psplash"
+INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."