]> code.ossystems Code Review - openembedded-core.git/commitdiff
parted: Add patches to fix build on musl
authorKhem Raj <raj.khem@gmail.com>
Thu, 16 Apr 2015 02:00:23 +0000 (19:00 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 21 Apr 2015 06:19:05 +0000 (07:19 +0100)
Theese patches are actually generic but expose issues
when compiling on musl

Change-Id: Ib5312af280d2c399334c5645fbea215737933ae5
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/parted/files/0001-Include-fcntl.h-in-platform_defs.h.patch [new file with mode: 0644]
meta/recipes-extended/parted/files/0001-Unset-need_charset_alias-when-building-for-musl.patch [new file with mode: 0644]
meta/recipes-extended/parted/parted_3.2.bb

diff --git a/meta/recipes-extended/parted/files/0001-Include-fcntl.h-in-platform_defs.h.patch b/meta/recipes-extended/parted/files/0001-Include-fcntl.h-in-platform_defs.h.patch
new file mode 100644 (file)
index 0000000..b0376ce
--- /dev/null
@@ -0,0 +1,29 @@
+From d78dd087c4ec4715aab5fe115668e726046ecd76 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 13 Apr 2015 18:16:05 -0700
+Subject: [PATCH] Include fcntl.h in /platform_defs.h
+
+exposed when compiling using musl
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ libparted/fs/xfs/platform_defs.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libparted/fs/xfs/platform_defs.h b/libparted/fs/xfs/platform_defs.h
+index 2b55752..32bd3d3 100644
+--- a/libparted/fs/xfs/platform_defs.h
++++ b/libparted/fs/xfs/platform_defs.h
+@@ -42,6 +42,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
++#include <fcntl.h>
+ #include <sys/param.h>
+ #include <sys/types.h>
+-- 
+2.1.4
+
diff --git a/meta/recipes-extended/parted/files/0001-Unset-need_charset_alias-when-building-for-musl.patch b/meta/recipes-extended/parted/files/0001-Unset-need_charset_alias-when-building-for-musl.patch
new file mode 100644 (file)
index 0000000..abdfa2a
--- /dev/null
@@ -0,0 +1,33 @@
+From b9565dc2fe0c4f7daaec91b7e83bc7313dee2f4a Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 13 Apr 2015 17:02:13 -0700
+Subject: [PATCH] Unset need_charset_alias when building for musl
+
+localcharset uses ac_cv_gnu_library_2_1 from glibc21.m4
+which actually shoudl be fixed in gnulib and then all downstream
+projects will get it eventually. For now we apply the fix to
+coreutils
+
+Upstream-Status: Not Required
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ lib/gnulib.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/gnulib.mk b/lib/gnulib.mk
+index e1d74db..c0e92dd 100644
+--- a/lib/gnulib.mk
++++ b/lib/gnulib.mk
+@@ -1882,7 +1882,7 @@ install-exec-localcharset: all-local
+         case '$(host_os)' in \
+           darwin[56]*) \
+             need_charset_alias=true ;; \
+-          darwin* | cygwin* | mingw* | pw32* | cegcc*) \
++          darwin* | cygwin* | mingw* | pw32* | cegcc* | linux-musl*) \
+             need_charset_alias=false ;; \
+           *) \
+             need_charset_alias=true ;; \
+-- 
+2.1.4
+
index e2257696d754e9e579b3c8197b4c2506f7072d4e..5d34749b010385d2b2394539a92bf46bc733cd07 100644 (file)
@@ -11,6 +11,8 @@ SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
            file://syscalls.patch \
            file://fix-doc-mandir.patch \
            file://fix-compile-failure-while-dis.patch \
+           file://0001-Include-fcntl.h-in-platform_defs.h.patch \
+           file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
            file://run-ptest \
            file://Makefile \
 "