]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto: detect and avoid branch revision checking for AUTOREV
authorBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 16 May 2011 15:42:28 +0000 (11:42 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 May 2011 13:38:52 +0000 (14:38 +0100)
When a BSP or layer specifies an AUTOREV for SRCREV, the logic
that matches expected vs real branch heads doesn't apply. We
always want the latest.

To solve the issues with invalid git revs causing validation
failures, we detect the AUTOINC value and do a early return,
skipping validation.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/classes/kernel-yocto.bbclass
meta/recipes-kernel/kern-tools/kern-tools-native_git.bb

index 818a07e21923d31652f4cc20a99eb51c084d1e15..536434fdf1aa908b650727f99a59d03edad68930 100644 (file)
@@ -136,6 +136,13 @@ do_validate_branches() {
                return
        fi
 
+       # nothing to do if SRCREV=${AUTOREV}
+       if [ "${SRCREV_machine}" = "AUTOINC" ]; then
+               # restore the branch for builds
+               git checkout -f ${KBRANCH}
+               return
+       fi
+
        branch_head=`git show-ref -s --heads ${KBRANCH}`
        meta_head=`git show-ref -s --heads ${KMETA}`
        target_branch_head="${SRCREV_machine}"
index 829d105d2c72be564c9dd4528cae56e2e9cce294..f7600ca5b651d33ece8d860fd4269aa7e1a0f385 100644 (file)
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=e2bf4415f3d8
 
 DEPENDS = "git-native guilt-native"
 
-SRCREV = "ecbdf3cdf6705a63dcb3c50bb24c311046f0b35c"
+SRCREV = "f8eb067b023d590b6cd8deddf6f96d6a820997af"
 PR = r10
 PV = "0.1+git${SRCPV}"